aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2017-06-18 17:40:01 +0200
committerJonas Gorski <jonas.gorski@gmail.com>2017-07-20 12:49:09 +0200
commit34c01e68b5d6b06ce3794ef0e2b06e81ec3ce8ca (patch)
tree0af7b9bc24445a75aef39d7d42e767343f715df8 /include/kernel.mk
parent6bdb662debf804d1c5049b7cdddc30591e42a1e1 (diff)
downloadupstream-34c01e68b5d6b06ce3794ef0e2b06e81ec3ce8ca.tar.gz
upstream-34c01e68b5d6b06ce3794ef0e2b06e81ec3ce8ca.tar.bz2
upstream-34c01e68b5d6b06ce3794ef0e2b06e81ec3ce8ca.zip
kernel: do not try to probe builtin modules on empty kmod package install
Builtin modules are always present, and trying to load them will cause modprobe to spew errors when installing the empty kmod packages. Fix this by never generating any postinst module install instructions for builtin modules. Fixes #842. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 7674f0dadc..d780ef0ce2 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -136,6 +136,7 @@ define ModuleAutoLoad
local mod; \
shift 2; \
for mod in $$$$$$$$mods; do \
+ [ -e $(2)/$(MODULES_SUBDIR)/$$$$$$$$mod.ko ] || continue; \
mkdir -p $(2)/etc/modules.d; \
echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$(1); \
done; \
@@ -154,6 +155,7 @@ define ModuleAutoLoad
local mod; \
shift 3; \
for mod in $$$$$$$$mods; do \
+ [ -e $(2)/$(MODULES_SUBDIR)/$$$$$$$$mod.ko ] || continue; \
mkdir -p $(2)/etc/modules.d; \
echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$$$$$$$$priority-$(1); \
done; \