aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2020-11-18 22:58:58 +0100
committerJo-Philipp Wich <jo@mein.io>2020-11-19 18:52:15 +0100
commit2127accd441b1c979c8f3f56f3ad5264542e185a (patch)
tree9ed16c08be161822ab418b94c3e45f85c79f15b6 /include/kernel.mk
parent8134c542e2e41d1156efe2a43d81304554a90540 (diff)
downloadupstream-2127accd441b1c979c8f3f56f3ad5264542e185a.tar.gz
upstream-2127accd441b1c979c8f3f56f3ad5264542e185a.tar.bz2
upstream-2127accd441b1c979c8f3f56f3ad5264542e185a.zip
build: create $(PKG_SYMVERS_DIR) if non-existent
Commit 5d76065 moved the creation of the symvers directory to include/kernel-build.mk. This is fine when building from scratch. But when unpacking an SDK the directory doesn't exist and because the kernel won't be built (again) this directory will not be created by the build system, causing build failure if make tries to copy files into it. This moves the creation of the symvers directory back into include/kernel.mk so that the directory is created in any case. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 1ae9c6be29..1466048b0c 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -149,6 +149,7 @@ define collect_module_symvers
grep -F $$$$realdir $(PKG_BUILD_DIR)/$$$$subdir/Module.symvers >> $(PKG_BUILD_DIR)/Module.symvers.tmp; \
done; \
sort -u $(PKG_BUILD_DIR)/Module.symvers.tmp > $(PKG_BUILD_DIR)/Module.symvers; \
+ mkdir -p $(PKG_SYMVERS_DIR); \
mv $(PKG_BUILD_DIR)/Module.symvers $(PKG_SYMVERS_DIR)/$(PKG_NAME).symvers
endef