aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel-build.mk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-11-18 14:32:23 +0100
committerPetr Štetiar <ynezz@true.cz>2019-11-24 14:19:43 +0100
commit74acc160a959b50776b9012dc9122734c8a110da (patch)
tree5233d86aa3173d06b66697b8851a667b80a5f5b5 /include/kernel-build.mk
parent68fb38548b1051f97879d771258b480c6b81a3da (diff)
downloadupstream-74acc160a959b50776b9012dc9122734c8a110da.tar.gz
upstream-74acc160a959b50776b9012dc9122734c8a110da.tar.bz2
upstream-74acc160a959b50776b9012dc9122734c8a110da.zip
kernel-build: ignore runtime config options during reconfig
Don't put CC_HAS_ASM_GOTO, IS_GCC, IS_CLANG and GCC_VERSION runtime config options into the kernel configs during reconfiguration as it makes no sense, since these options should be set at runtime. Fixes: FS#2588 Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'include/kernel-build.mk')
-rw-r--r--include/kernel-build.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 684fbd34d3..b1d3fc07fd 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -165,7 +165,9 @@ define BuildKernel
$(if $(findstring Darwin,$(HOST_OS)),HOST_LOADLIBES="-L$(STAGING_DIR_HOST)/lib -lncurses") \
YACC=$(STAGING_DIR_HOST)/bin/bison \
$$@
- $(LINUX_RECONF_DIFF) $(LINUX_DIR)/.config > $(LINUX_RECONFIG_TARGET)
+ $(LINUX_RECONF_DIFF) $(LINUX_DIR)/.config | \
+ grep -vE '(CONFIG_CC_(HAS_ASM_GOTO|IS_GCC|IS_CLANG)|GCC_VERSION)=' \
+ > $(LINUX_RECONFIG_TARGET)
install: $(LINUX_DIR)/.image
+$(MAKE) -C image compile install TARGET_BUILD=