aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2020-04-07 14:26:42 +0200
committerFelix Fietkau <nbd@nbd.name>2020-04-09 09:54:02 +0200
commit5c6fe8e850a74d65a94d674c92ee6147a3db92aa (patch)
tree8cc68cd6b3b70252476ca94c534c8dc689333afe /include/kernel-build.mk
parentcd510e775bc7c806b3ad6981221258385554b9e8 (diff)
downloadupstream-5c6fe8e850a74d65a94d674c92ee6147a3db92aa.tar.gz
upstream-5c6fe8e850a74d65a94d674c92ee6147a3db92aa.tar.bz2
upstream-5c6fe8e850a74d65a94d674c92ee6147a3db92aa.zip
build: fix kernel_menuconfig on macOS with newer kernel versions
Account for upstream build system changes Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/kernel-build.mk')
-rw-r--r--include/kernel-build.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index b1d3fc07fd..c371e78ab9 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -162,7 +162,11 @@ define BuildKernel
rm -f $(STAMP_CONFIGURED)
$(LINUX_RECONF_CMD) > $(LINUX_DIR)/.config
$(_SINGLE)$(KERNEL_MAKE) \
- $(if $(findstring Darwin,$(HOST_OS)),HOST_LOADLIBES="-L$(STAGING_DIR_HOST)/lib -lncurses") \
+ $(if $(findstring Darwin,$(HOST_OS)), \
+ HOST_LOADLIBES="-L$(STAGING_DIR_HOST)/lib -lncurses" \
+ HOSTLDLIBS_mconf="-L$(STAGING_DIR_HOST)/lib -lncurses" \
+ filechk_conf_cfg=" :" \
+ ) \
YACC=$(STAGING_DIR_HOST)/bin/bison \
$$@
$(LINUX_RECONF_DIFF) $(LINUX_DIR)/.config | \