aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2019-09-06 14:55:36 +0200
committerJonas Gorski <jonas.gorski@gmail.com>2019-09-07 14:45:32 +0200
commitf11d90a76b719106336b94d85b166b4ebf19dbb0 (patch)
tree046a6ab3a4254ac61ecaa09d9467c02a5c863e7a /include/image.mk
parent1855c237948e211849d79765ca749cdea6a79987 (diff)
downloadupstream-f11d90a76b719106336b94d85b166b4ebf19dbb0.tar.gz
upstream-f11d90a76b719106336b94d85b166b4ebf19dbb0.tar.bz2
upstream-f11d90a76b719106336b94d85b166b4ebf19dbb0.zip
Revert "build: remove harmful -nopad option from mksquashfs"
This reverts commit 1c0290c5cc6258c48b8ba46b4f9c85a21de4f875. Dropping the nopad can make the padding overflow into the next erase block on devices using a non-aligned rootfs start. This breaks the jffs2 overlay partition with the following messages: [ 30.343877] jffs2_scan_eraseblock(): End of filesystem marker found at 0x10000 [ 30.376512] jffs2: Cowardly refusing to erase blocks on filesystem with no valid JFFS2 nodes [ 30.385253] jffs2: empty_blocks 196, bad_blocks 0, c->nr_blocks 197 Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 599adfaa10..5d54bc7947 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -240,7 +240,7 @@ $(eval $(foreach S,$(NAND_BLOCKSIZE),$(call Image/mkfs/jffs2-nand/template,$(S))
define Image/mkfs/squashfs
$(STAGING_DIR_HOST)/bin/mksquashfs4 $(call mkfs_target_dir,$(1)) $@ \
- -noappend -root-owned \
+ -nopad -noappend -root-owned \
-comp $(SQUASHFSCOMP) $(SQUASHFSOPT) \
-processors 1
endef