aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-09-27 17:10:34 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-09-27 17:22:01 +0100
commite8b34880f9776264837d0ba1604ef602ac93882e (patch)
treea61c8a893c0c1cf05d57908372292e976dabe752 /include/image.mk
parent96023cd4ba66c33e77d9df562dda44b0a1ba1ac9 (diff)
downloadupstream-e8b34880f9776264837d0ba1604ef602ac93882e.tar.gz
upstream-e8b34880f9776264837d0ba1604ef602ac93882e.tar.bz2
upstream-e8b34880f9776264837d0ba1604ef602ac93882e.zip
policycoreutils: fix host utils rpath and bin directory
'setfiles' and others should be installed to $(STAGING_DIR_HOSTPKG)/bin rather than $(...)/sbin which isn't in PATH. Also using -Wl,-rpath to set library search location instead of setting LD_LIBRARY_PATH when calling setfiles in image.mk. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index a1308f47ad..da3d500e81 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -243,8 +243,7 @@ endef
ifeq ($(CONFIG_TARGET_ROOTFS_SECURITY_LABELS),y)
define Image/mkfs/squashfs
- echo "LD_LIBRARY_PATH=\$$LD_LIBRARY_PATH:$(STAGING_DIR_HOSTPKG)/lib" \
- "$(STAGING_DIR_HOSTPKG)/sbin/setfiles -r" \
+ echo "$(STAGING_DIR_HOSTPKG)/bin/setfiles -r" \
"$(call mkfs_target_dir,$(1))" \
"$(call mkfs_target_dir,$(1))/etc/selinux/targeted/contexts/files/file_contexts " \
"$(call mkfs_target_dir,$(1))" > $@.fakeroot-script