aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2019-08-11 23:08:33 -1000
committerDaniel Golle <daniel@makrotopia.org>2019-08-13 10:40:36 +0200
commitdfe99645dbdd4460f394beaa3a05091cd40b5942 (patch)
tree29949c5d3431bdd1e6579ac708692e900a000b89 /include/image.mk
parent454021581f630d5d04afeb8ff6581c1bda295c87 (diff)
downloadupstream-dfe99645dbdd4460f394beaa3a05091cd40b5942.tar.gz
upstream-dfe99645dbdd4460f394beaa3a05091cd40b5942.tar.bz2
upstream-dfe99645dbdd4460f394beaa3a05091cd40b5942.zip
image.mk: remove device_ from manifest filename
The manifest file is based on IMG_PREFIX and PROFILE_SANITIZED, whereas the latter takes a string like DEVICE_8dev_carambola2 and sanitizes it. This behaviour results in a useless "device_" profile-prefix in the device manifest filename. Now uses *subst* to remove that. Therefore this patch results more consistent device file names: openwrt-ath79-generic-8dev_carambola2-initramfs-kernel.bin openwrt-ath79-generic-8dev-carambola2.manifest openwrt-ath79-generic-8dev_carambola2-squashfs-sysupgrade.bin instead of a single file being called openwrt-ath79-generic-device_8dev-carambola2.manifest Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index e55ac22d0d..c6a6ab7993 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -106,7 +106,7 @@ define add_jffs2_mark
echo -ne '\xde\xad\xc0\xde' >> $(1)
endef
-PROFILE_SANITIZED := $(call sanitize,$(PROFILE))
+PROFILE_SANITIZED := $(call sanitize,$(subst DEVICE_,,$(PROFILE)))
define split_args
$(foreach data, \