aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2022-11-22 00:37:39 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2022-12-22 00:14:30 +0100
commitda79da3ac18995885e3fe0e540ce300ad6d768be (patch)
tree9df00b45efd22d868c8471517b11627adbaee16a /include/image.mk
parent9aa95bbebb07554ccf6f611ead081f85e1f8b902 (diff)
downloadupstream-da79da3ac18995885e3fe0e540ce300ad6d768be.tar.gz
upstream-da79da3ac18995885e3fe0e540ce300ad6d768be.tar.bz2
upstream-da79da3ac18995885e3fe0e540ce300ad6d768be.zip
image: fix device profile specific COMPILE targets
Commit a01d23e75 ("image: always rebuild kernel loaders") is a step in the right direction, but exposed some issues and regressions in the makefile. Some of the files made by device specific COMPILE targets start with an "append" command (i.e. >> instead of > redirection) and if the file already exists, the target file is the input to itself before the first recipe-specified input. Fixes: a01d23e75 ("image: always rebuild kernel loaders") Fixes: a7fb589e8 ("image: always rebuild kernel loaders") Signed-off-by: Michael Pratt <mcpratt@pm.me> (cherry picked from commit 1bff0752bd5e7feb0f311224a09b3bf217a9aeb3)
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index c7a2e082ab..ba1bd3c03f 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -525,6 +525,7 @@ define Device/Build/compile
$$(_COMPILE_TARGET): $(KDIR)/$(1)
$(eval $(call Device/Export,$(KDIR)/$(1)))
$(KDIR)/$(1): FORCE
+ rm -f $(KDIR)/$(1)
$$(call concat_cmd,$(COMPILE/$(1)))
endef