aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-03 01:21:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-03 01:21:41 +0000
commitd6666fdd40872ba03f2a5029cd0e32ae807befd0 (patch)
treed218a77be0261103f905c2c40808626dc5028ba4 /include/image.mk
parent0f74fa296c1b76ad1cb809b790dea7640e3c0562 (diff)
downloadupstream-d6666fdd40872ba03f2a5029cd0e32ae807befd0.tar.gz
upstream-d6666fdd40872ba03f2a5029cd0e32ae807befd0.tar.bz2
upstream-d6666fdd40872ba03f2a5029cd0e32ae807befd0.zip
fix image installation
SVN-Revision: 8324
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index d00f779fe9..b094428770 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -8,6 +8,9 @@
include $(INCLUDE_DIR)/prereq.mk
include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/host.mk
+
+override MAKEFLAGS=
+override MAKE:=$(SUBMAKE)
KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
ifneq ($(CONFIG_BIG_ENDIAN),y)
@@ -94,14 +97,14 @@ define BuildImage
download:
prepare:
ifneq ($(IB),1)
- compile: compile-targets
+ compile: compile-targets FORCE
$(call Build/Compile)
else
compile:
endif
ifneq ($(IB),1)
- install: compile install-targets
+ install: compile install-targets FORCE
$(call Image/Prepare)
$(call Image/mkfs/prepare)
$(call Image/BuildKernel)