aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2019-11-04 10:55:23 -1000
committerPetr Štetiar <ynezz@true.cz>2019-11-11 16:37:13 +0100
commit98d1c7d83485ed2b024bf8ab5f8ff7e2a66ab85e (patch)
tree63e5c237d4c23c2e11018d815b202990a72762fb /include/image.mk
parent1c321237c29202e0ed5c168c625cc89fcabb609c (diff)
downloadupstream-98d1c7d83485ed2b024bf8ab5f8ff7e2a66ab85e.tar.gz
upstream-98d1c7d83485ed2b024bf8ab5f8ff7e2a66ab85e.tar.bz2
upstream-98d1c7d83485ed2b024bf8ab5f8ff7e2a66ab85e.zip
build: image: add common and reproducible IMG_PART_SIGNATURE variable
x86, mvebu and tegra targets are currently using more or less same SIGNATURE variable which provides unique partition ID/signature, so it makes sense to refactor it out into common variable which could be reused by all targets. While at it, make the content of the variable reproducible. Ref: http://lists.infradead.org/pipermail/openwrt-devel/2019-March/016148.html Signed-off-by: Paul Spooren <mail@aparcar.org> Suggested-by: Jo-Philipp Wich <jo@mein.io> [renamed to IMG_PARTSIGNATURE, reworked with epoch+vermagic hash] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 77d4567197..8755c4832a 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -44,6 +44,7 @@ IMG_PREFIX_VERCODE:=$(if $(CONFIG_VERSION_CODE_FILENAMES),$(call sanitize,$(VERS
IMG_PREFIX:=$(VERSION_DIST_SANITIZED)-$(IMG_PREFIX_VERNUM)$(IMG_PREFIX_VERCODE)$(IMG_PREFIX_EXTRA)$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))
IMG_ROOTFS:=$(IMG_PREFIX)-rootfs
IMG_COMBINED:=$(IMG_PREFIX)-combined
+IMG_PART_SIGNATURE:=$(shell echo $(SOURCE_DATE_EPOCH)$(LINUX_VERMAGIC) | mkhash md5 | head --bytes 8)
MKFS_DEVTABLE_OPT := -D $(INCLUDE_DIR)/device_table.txt