aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-02 17:24:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-02 17:24:20 +0000
commit91e5dba2c76d9185cc06c32feb51b8b0d1c310ca (patch)
tree33c544be12c7aaaaff28f785b5ae40263645fe9a /include/image.mk
parent983544f859e946494b3029a41bb7880b93c46037 (diff)
downloadupstream-91e5dba2c76d9185cc06c32feb51b8b0d1c310ca.tar.gz
upstream-91e5dba2c76d9185cc06c32feb51b8b0d1c310ca.tar.bz2
upstream-91e5dba2c76d9185cc06c32feb51b8b0d1c310ca.zip
kernel build cleanup
SVN-Revision: 6464
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index 9c170af11b..78e1a2fdc8 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -61,8 +61,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
tar -zcf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tgz --owner=root --group=root -C $(BUILD_DIR)/root/ .
endef
endif
-
-
+else
+ define Image/BuildKernel
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
+ endef
endif