aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-10-09 20:33:34 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-10-23 18:39:29 -0700
commit818f36aa140d930e5de957eeb81f32f4d96a4bbb (patch)
tree3abae7ec606235263d485b0cf481188b285ed01d /include/image.mk
parent834810617edba87e43f7b58fa32800155eea9aef (diff)
downloadupstream-818f36aa140d930e5de957eeb81f32f4d96a4bbb.tar.gz
upstream-818f36aa140d930e5de957eeb81f32f4d96a4bbb.tar.bz2
upstream-818f36aa140d930e5de957eeb81f32f4d96a4bbb.zip
include: Include new location for DT bindings
Starting with commit d5d332d3f7e8 ("devicetree: Move include prefixes from arch to separate directory") included in 4.12 and newer relocated the dt-bindings directory, so account for that while passing CPPFLAGS before DTC runs. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 3f5b4544e9..fc6bf06e96 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -161,6 +161,7 @@ define Image/BuildDTB
$(TARGET_CROSS)cpp -nostdinc -x assembler-with-cpp \
-I$(DTS_DIR) \
-I$(DTS_DIR)/include \
+ -I$(LINUX_DIR)/include/ \
-undef -D__DTS__ $(3) \
-o $(2).tmp $(1)
$(LINUX_DIR)/scripts/dtc/dtc -O dtb \