aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-03-21 17:16:50 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-03-21 17:16:50 +0000
commit7af8ee04812f647ce74adbe04f0d5d18a39bbd29 (patch)
tree9a50a2973e0866572e2cf8394d65dba645ac3c08 /include/image.mk
parente7f046805af93c3af6d318907033cf0d803e4b34 (diff)
downloadupstream-7af8ee04812f647ce74adbe04f0d5d18a39bbd29.tar.gz
upstream-7af8ee04812f647ce74adbe04f0d5d18a39bbd29.tar.bz2
upstream-7af8ee04812f647ce74adbe04f0d5d18a39bbd29.zip
change from /jffs to /overlay, patch from Daniel Dickinson
SVN-Revision: 20356
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index 47871f9541..0ce6336cc5 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -62,14 +62,13 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
$(call Image/Build,jffs2-$(1))
endef
define Image/mkfs/jffs2
- rm -rf $(TARGET_DIR)/jffs
$(foreach SZ,$(JFFS2_BLOCKSIZE),$(call Image/mkfs/jffs2/sub,$(SZ)))
endef
endif
ifeq ($(CONFIG_TARGET_ROOTFS_SQUASHFS),y)
define Image/mkfs/squashfs
- @mkdir -p $(TARGET_DIR)/jffs
+ @mkdir -p $(TARGET_DIR)/overlay
$(MKSQUASHFS_CMD) $(TARGET_DIR) $(KDIR)/root.squashfs -nopad -noappend -root-owned $(SQUASHFS_OPTS)
$(call Image/Build,squashfs)
endef