aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-06-30 01:02:43 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-06-30 23:21:10 +0100
commit263f7e5bbd119ebed1f514c16f659a2e2a2b132c (patch)
treeb50da617aefe789d22d9de6f1a23913705771875 /include/image.mk
parentd4c80f5b172e3e3a209fdd64c73be535e360db34 (diff)
downloadupstream-263f7e5bbd119ebed1f514c16f659a2e2a2b132c.tar.gz
upstream-263f7e5bbd119ebed1f514c16f659a2e2a2b132c.tar.bz2
upstream-263f7e5bbd119ebed1f514c16f659a2e2a2b132c.zip
build: store default/device packages in JSON
With this commit the `profiles.json` contain both the target specific `default_packages` as well as the device specific `device_packages` as a array of strings. This information is required for downstream projects like the various web-based interactive firmware generators. Signed-off-by: Daniel Golle <daniel@makrotopia.org> Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 984b64fb9c..300f7a6619 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -592,6 +592,7 @@ define Device/Build/image
DEVICE_ALT2_MODEL="$(DEVICE_ALT2_MODEL)" \
DEVICE_ALT2_VARIANT="$(DEVICE_ALT2_VARIANT)" \
DEVICE_TITLE="$(DEVICE_TITLE)" \
+ DEVICE_PACKAGES="$(DEVICE_PACKAGES)" \
TARGET="$(BOARD)" \
SUBTARGET="$(if $(SUBTARGET),$(SUBTARGET),generic)" \
VERSION_NUMBER="$(VERSION_NUMBER)" \