aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2020-08-29 22:48:49 +0200
committerChristian Lamparter <chunkeey@gmail.com>2020-09-25 19:32:33 +0200
commitfed1788689a180fa6f0ac2bc0f8f4659e8026e84 (patch)
tree2a91ecebe8ea60f7701a0c9d178505f3b604c9b1 /include/image-commands.mk
parenta9071d02b5ab11fbd73ea42076a09f2fd8136517 (diff)
downloadupstream-fed1788689a180fa6f0ac2bc0f8f4659e8026e84.tar.gz
upstream-fed1788689a180fa6f0ac2bc0f8f4659e8026e84.tar.bz2
upstream-fed1788689a180fa6f0ac2bc0f8f4659e8026e84.zip
scripts: mkits.sh make it possible to specify fdt@#
Some bootloaders are really keen on just one special fdt in a multi-image fit image. This is a problem, because currently this is fixed to "fdt@1". This patch introduces a new device variable: DEVICE_FDT_NUM that allows to specify the right fdt number. If the value is absent "1" will be chosen. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 9516801c8d..740d627fc7 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -158,6 +158,7 @@ define Build/fit
-D $(DEVICE_NAME) -o $@.its -k $@ \
$(if $(word 2,$(1)),-d $(word 2,$(1))) -C $(word 1,$(1)) \
-a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+ $(if $(DEVICE_FDT_NUM),-n $(DEVICE_FDT_NUM)) \
-c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config@1") \
-A $(LINUX_KARCH) -v $(LINUX_VERSION)
PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $@.its $@.new