aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2019-02-26 13:04:54 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2019-02-26 13:38:47 +0100
commitfe90e48c39c46b3c253b65f38e392c43f6abe2f0 (patch)
tree2ba31e23eb6a6e9b3771e6ad77786a0184ad5166 /include/image-commands.mk
parent9bf63d03399c1982db997397d3486c4864fb80e1 (diff)
downloadupstream-fe90e48c39c46b3c253b65f38e392c43f6abe2f0.tar.gz
upstream-fe90e48c39c46b3c253b65f38e392c43f6abe2f0.tar.bz2
upstream-fe90e48c39c46b3c253b65f38e392c43f6abe2f0.zip
build: qsdk-ipq-*: include dtc in PATH before calling mkimage
Use 'dtc' from kernel sources instead of relying on host tool. Fixes: bf4630e5adb4 ("build: add helpers for generating QSDK sysupgrade compatible images") Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 47d7193434..ade370cc0d 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -297,14 +297,14 @@ endef
define Build/qsdk-ipq-factory-nand
$(TOPDIR)/scripts/mkits-qsdk-ipq-image.sh \
$@.its ubi $@
- mkimage -f $@.its $@.new
+ PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $@.its $@.new
@mv $@.new $@
endef
define Build/qsdk-ipq-factory-nor
$(TOPDIR)/scripts/mkits-qsdk-ipq-image.sh \
$@.its hlos $(IMAGE_KERNEL) rootfs $(IMAGE_ROOTFS)
- mkimage -f $@.its $@.new
+ PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $@.its $@.new
@mv $@.new $@
endef