aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-12-29 20:06:56 +0100
committerMathias Kresin <dev@kresin.me>2018-12-30 20:08:13 +0100
commitfd35c5b205e7583628472b607ee4eb41c6d1b6d5 (patch)
tree8b0d527866725410ed25cbbb4a7d7361837aa2bb /include/image-commands.mk
parentde42466528b4e5748d18af9396a4226b0c1cd0fa (diff)
downloadupstream-fd35c5b205e7583628472b607ee4eb41c6d1b6d5.tar.gz
upstream-fd35c5b205e7583628472b607ee4eb41c6d1b6d5.tar.bz2
upstream-fd35c5b205e7583628472b607ee4eb41c6d1b6d5.zip
build: move seama commands to image-commands.mk
Move it to image-commands.mk to get rid of duplicate recipes. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 65fa36d2be..c5b64c751d 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -49,6 +49,18 @@ define Build/eva-image
mv $@.new $@
endef
+define Build/seama
+ $(STAGING_DIR_HOST)/bin/seama -i $@ \
+ -m "dev=/dev/mtdblock/$(SEAMA_MTDBLOCK)" -m "type=firmware"
+ mv $@.seama $@
+endef
+
+define Build/seama-seal
+ $(STAGING_DIR_HOST)/bin/seama -i $@ -s $@.seama \
+ -m "signature=$(SEAMA_SIGNATURE)"
+ mv $@.seama $@
+endef
+
define Build/zyxel-ras-image
let \
newsize="$(subst k,* 1024,$(RAS_ROOTFS_SIZE))"; \