aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2019-10-21 16:26:07 +0200
committerJohn Crispin <john@phrozen.org>2019-10-21 16:26:24 +0200
commitf4aaee01faea1998b2403ffe951fe6100fb4e587 (patch)
tree1b01f1928f7ac84054b7560bc93f03cbd25e630c /include/image-commands.mk
parent4408723d42e0d717a0643422690686187cc7c2b1 (diff)
downloadupstream-f4aaee01faea1998b2403ffe951fe6100fb4e587.tar.gz
upstream-f4aaee01faea1998b2403ffe951fe6100fb4e587.tar.bz2
upstream-f4aaee01faea1998b2403ffe951fe6100fb4e587.zip
Revert "build: separate signing logic"
This reverts commit 4a45e69d190f72ed94878487b271ed7651dd9efa. This broke the buildbots Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk13
1 files changed, 5 insertions, 8 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 3d10b18bc8..5dfd6a2c2f 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -373,14 +373,11 @@ metadata_json = \
define Build/append-metadata
$(if $(SUPPORTED_DEVICES),-echo $(call metadata_json,$(SUPPORTED_DEVICES)) | fwtool -I - $@)
- [ -z "$(SIGNED_IMAGES)" \
- -o ! -s "$(BUILD_KEY)" \
- -o ! -s "$(BUILD_KEY).ucert" \
- -o ! -s "$@" ] || { \
- cp "$(BUILD_KEY).ucert" "$@.ucert" ;\
- usign -S -m "$@" -s "$(BUILD_KEY)" -x "$@.sig" ;\
- ucert -A -c "$@.ucert" -x "$@.sig" ;\
- fwtool -S "$@.ucert" "$@" ;\
+ [ ! -s "$(BUILD_KEY)" -o ! -s "$(BUILD_KEY).ucert" -o ! -s "$@" ] || { \
+ cp "$(BUILD_KEY).ucert" "$@.ucert" ;\
+ usign -S -m "$@" -s "$(BUILD_KEY)" -x "$@.sig" ;\
+ ucert -A -c "$@.ucert" -x "$@.sig" ;\
+ fwtool -S "$@.ucert" "$@" ;\
}
endef