aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-12-30 11:53:21 +0100
committerMathias Kresin <dev@kresin.me>2017-06-24 22:36:38 +0200
commite7cd6f5d66b827e31cfa7e7bc019ac1b86aac770 (patch)
tree2266d211229d5045d0ea8d4e998164641272a5b7 /include/image-commands.mk
parent0605b15be405ddaf9499e02f4b5a59ba406d2ccd (diff)
downloadupstream-e7cd6f5d66b827e31cfa7e7bc019ac1b86aac770.tar.gz
upstream-e7cd6f5d66b827e31cfa7e7bc019ac1b86aac770.tar.bz2
upstream-e7cd6f5d66b827e31cfa7e7bc019ac1b86aac770.zip
ar71xx: add AVM FRITZ!WLAN Repeater 300E support
Specifications: * SoC: AR7242 (Virian 400MHz) * RAM: 64 MB DDR (W9751G6JB-25) * Flash: 16MB SPI flash (S25FL129PIF) * WiFi: AR9382 (2.4/5GHz) + 2x SE2595L * LAN: 1x1000M (PEF7071V) To install LEDE via EVA bootloader, a FTP connection need to be established to 192.168.178.1 within the first seconds after power on: ftp> quote USER adam2 ftp> quote PASS adam2 ftp> binary ftp> debug ftp> passive ftp> quote MEDIA FLSH ftp> put lede-ar71xx-generic-fritz300e-squashfs-sysupgrade.bin mtd1 Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 093b93d0e9..8607c85e9e 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -67,6 +67,16 @@ define Build/netgear-dni
mv $@.new $@
endef
+define Build/append-squashfs-fakeroot-be
+ rm -rf $@.fakefs $@.fakesquashfs
+ mkdir $@.fakefs
+ $(STAGING_DIR_HOST)/bin/mksquashfs-lzma \
+ $@.fakefs $@.fakesquashfs \
+ -noappend -root-owned -be -nopad -b 65536 \
+ $(if $(SOURCE_DATE_EPOCH),-fixed-time $(SOURCE_DATE_EPOCH))
+ cat $@.fakesquashfs >> $@
+endef
+
# append a fake/empty rootfs uImage header, to fool the bootloaders
# rootfs integrity check
define Build/append-uImage-fakeroot-hdr