aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2018-12-12 21:12:27 +0900
committerChristian Lamparter <chunkeey@gmail.com>2018-12-24 19:18:07 +0100
commit99df98442e1101607e3e6c902d5d957e72cea1d6 (patch)
tree833b9cd77226e47d091cb9a32462e8104a1d03cd /include/image-commands.mk
parent9145f5209fc33a019a652ce87832f48fa50aefc8 (diff)
downloadupstream-99df98442e1101607e3e6c902d5d957e72cea1d6.tar.gz
upstream-99df98442e1101607e3e6c902d5d957e72cea1d6.tar.bz2
upstream-99df98442e1101607e3e6c902d5d957e72cea1d6.zip
build: move xor-image into image-commands
I moved xor-image into image-commands.mk to use it in ath79 target. It required for NEC WG800HP. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 5e24c5e3aa..65fa36d2be 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -242,6 +242,11 @@ define Build/pad-offset
mv $@.new $@
endef
+define Build/xor-image
+ $(STAGING_DIR_HOST)/bin/xorimage -i $@ -o $@.xor $(1)
+ mv $@.xor $@
+endef
+
define Build/check-size
@[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -ge "$$(stat -c%s $@)" ] || { \
echo "WARNING: Image file $@ is too big" >&2; \