aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-29 21:00:11 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-02 15:54:43 +0200
commit93d37fad86312850450c45b56ff5367c0009ff7a (patch)
tree16a336459c2e252c8569a44f819b15188a240258 /include/image-commands.mk
parent8d131986552b9b492fd98a02280803a44f3fda20 (diff)
downloadupstream-93d37fad86312850450c45b56ff5367c0009ff7a.tar.gz
upstream-93d37fad86312850450c45b56ff5367c0009ff7a.tar.bz2
upstream-93d37fad86312850450c45b56ff5367c0009ff7a.zip
build: image: drop unused check-kernel-size recipe
The recipe check-kernel-size is not used in the entire tree. Instead, we already check the size of the kernel image in Device/Build/kernel in image.mk via check-size function if KERNEL_SIZE is defined. Therefore, drop the function. Using it would be redundant anyway. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk7
1 files changed, 0 insertions, 7 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 7a370034c8..9281b91990 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -275,13 +275,6 @@ define Build/check-size
}
endef
-define Build/check-kernel-size
- @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -ge "$$(stat -c%s $(IMAGE_KERNEL))" ] || { \
- echo "WARNING: Kernel for $@ is too big > $(1)" >&2; \
- rm -f $@; \
- }
-endef
-
define Build/combined-image
-sh $(TOPDIR)/scripts/combined-image.sh \
"$(IMAGE_KERNEL)" \