aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-10-30 19:21:37 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-10-30 19:23:00 +0100
commit8af6dfc01c01b2d6b476cd3e87de1604f8e48564 (patch)
tree2bd0fd6168e959a267ddc8d70db78b0673d40fd1 /include/image-commands.mk
parent1cdba3d19e32fcfc32037ceb3591e6c78fc34f20 (diff)
downloadupstream-8af6dfc01c01b2d6b476cd3e87de1604f8e48564.tar.gz
upstream-8af6dfc01c01b2d6b476cd3e87de1604f8e48564.tar.bz2
upstream-8af6dfc01c01b2d6b476cd3e87de1604f8e48564.zip
image: sort image-commands.mk alphabetically
The definitions in image-commands.mk seem to have no particular order. Sort them alphabetically to make it easier to actually find anything there. No other changes made beyond moving entire blocks. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk429
1 files changed, 215 insertions, 214 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 454ce79e07..438f1e87e4 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -7,93 +7,61 @@ define rootfs_align
$(patsubst %-256k,0x40000,$(patsubst %-128k,0x20000,$(patsubst %-64k,0x10000,$(patsubst squashfs%,0x4,$(patsubst root.%,%,$(1))))))
endef
-define Build/uImage
- mkimage -A $(LINUX_KARCH) \
- -O linux -T kernel \
- -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' -d $@ $@.new
- mv $@.new $@
-endef
-define Build/buffalo-enc
- $(eval product=$(word 1,$(1)))
- $(eval version=$(word 2,$(1)))
- $(eval args=$(wordlist 3,$(words $(1)),$(1)))
- $(STAGING_DIR_HOST)/bin/buffalo-enc \
- -p $(product) -v $(version) $(args) \
- -i $@ -o $@.new
- mv $@.new $@
-endef
-
-define Build/buffalo-enc-tag
- $(call Build/buffalo-enc,'' '' -S 152 $(1))
-endef
-
-define Build/buffalo-tag-dhp
- $(eval product=$(word 1,$(1)))
- $(eval region=$(word 2,$(1)))
- $(eval language=$(word 3,$(1)))
- $(STAGING_DIR_HOST)/bin/buffalo-tag \
- -d 0x01000000 -w 1 \
- -a $(BUFFALO_TAG_PLATFORM) \
- -v $(BUFFALO_TAG_VERSION) -m $(BUFFALO_TAG_MINOR) \
- -b $(product) -p $(product) \
- -r $(region) -r $(region) -l $(language) \
- -I $@ -o $@.new
- mv $@.new $@
+define Build/append-dtb
+ cat $(KDIR)/image-$(firstword $(DEVICE_DTS)).dtb >> $@
endef
-define Build/buffalo-dhp-image
- $(STAGING_DIR_HOST)/bin/mkdhpimg $@ $@.new
- mv $@.new $@
+define Build/append-dtb-elf
+ $(TARGET_CROSS)objcopy \
+ --set-section-flags=.appended_dtb=alloc,contents \
+ --update-section \
+ .appended_dtb=$(KDIR)/image-$(firstword $(DEVICE_DTS)).dtb $@
endef
-define Build/eva-image
- $(STAGING_DIR_HOST)/bin/lzma2eva $(KERNEL_LOADADDR) $(KERNEL_LOADADDR) $@ $@.new
- mv $@.new $@
+define Build/append-kernel
+ dd if=$(IMAGE_KERNEL) >> $@
endef
-define Build/seama
- $(STAGING_DIR_HOST)/bin/seama -i $@ \
- -m "dev=/dev/mtdblock/$(SEAMA_MTDBLOCK)" -m "type=firmware"
- mv $@.seama $@
-endef
+compat_version=$(if $(DEVICE_COMPAT_VERSION),$(DEVICE_COMPAT_VERSION),1.0)
+json_quote=$(subst ','\'',$(subst ",\",$(1)))
+#")')
-define Build/seama-seal
- $(STAGING_DIR_HOST)/bin/seama -i $@ -s $@.seama \
- -m "signature=$(SEAMA_SIGNATURE)"
- mv $@.seama $@
-endef
+legacy_supported_message=$(SUPPORTED_DEVICES) - Image version mismatch: image $(compat_version), \
+ device 1.0. Please wipe config during upgrade (force required) or reinstall. \
+ $(if $(DEVICE_COMPAT_MESSAGE),Reason: $(DEVICE_COMPAT_MESSAGE),Please check documentation ...)
-define Build/zyxel-ras-image
- let \
- newsize="$(subst k,* 1024,$(RAS_ROOTFS_SIZE))"; \
- $(STAGING_DIR_HOST)/bin/mkrasimage \
- -b $(RAS_BOARD) \
- -v $(RAS_VERSION) \
- -r $@ \
- -s $$newsize \
- -o $@.new \
- $(if $(findstring separate-kernel,$(word 1,$(1))),-k $(IMAGE_KERNEL)) \
- && mv $@.new $@
-endef
+metadata_devices=$(if $(1),$(subst "$(space)","$(comma)",$(strip $(foreach v,$(1),"$(call json_quote,$(v))"))))
+metadata_json = \
+ '{ $(if $(IMAGE_METADATA),$(IMAGE_METADATA)$(comma)) \
+ "metadata_version": "1.1", \
+ "compat_version": "$(call json_quote,$(compat_version))", \
+ $(if $(DEVICE_COMPAT_MESSAGE),"compat_message": "$(call json_quote,$(DEVICE_COMPAT_MESSAGE))"$(comma)) \
+ $(if $(filter-out 1.0,$(compat_version)),"new_supported_devices": \
+ [$(call metadata_devices,$(SUPPORTED_DEVICES))]$(comma) \
+ "supported_devices": ["$(call json_quote,$(legacy_supported_message))"]$(comma)) \
+ $(if $(filter 1.0,$(compat_version)),"supported_devices":[$(call metadata_devices,$(SUPPORTED_DEVICES))]$(comma)) \
+ "version": { \
+ "dist": "$(call json_quote,$(VERSION_DIST))", \
+ "version": "$(call json_quote,$(VERSION_NUMBER))", \
+ "revision": "$(call json_quote,$(REVISION))", \
+ "target": "$(call json_quote,$(TARGETID))", \
+ "board": "$(call json_quote,$(if $(BOARD_NAME),$(BOARD_NAME),$(DEVICE_NAME)))" \
+ } \
+ }'
-define Build/netgear-chk
- $(STAGING_DIR_HOST)/bin/mkchkimg \
- -o $@.new \
- -k $@ \
- -b $(NETGEAR_BOARD_ID) \
- $(if $(NETGEAR_REGION),-r $(NETGEAR_REGION),)
- mv $@.new $@
+define Build/append-metadata
+ $(if $(SUPPORTED_DEVICES),-echo $(call metadata_json) | fwtool -I - $@)
+ [ ! -s "$(BUILD_KEY)" -o ! -s "$(BUILD_KEY).ucert" -o ! -s "$@" ] || { \
+ cp "$(BUILD_KEY).ucert" "$@.ucert" ;\
+ usign -S -m "$@" -s "$(BUILD_KEY)" -x "$@.sig" ;\
+ ucert -A -c "$@.ucert" -x "$@.sig" ;\
+ fwtool -S "$@.ucert" "$@" ;\
+ }
endef
-define Build/netgear-dni
- $(STAGING_DIR_HOST)/bin/mkdniimg \
- -B $(NETGEAR_BOARD_ID) -v $(VERSION_DIST).$(firstword $(subst -, ,$(REVISION))) \
- $(if $(NETGEAR_HW_ID),-H $(NETGEAR_HW_ID)) \
- -r "$(1)" \
- -i $@ -o $@.new
- mv $@.new $@
+define Build/append-rootfs
+ dd if=$(IMAGE_ROOTFS) >> $@
endef
define Build/append-squashfs-fakeroot-be
@@ -110,6 +78,25 @@ define Build/append-string
echo -n $(1) >> $@
endef
+define Build/append-ubi
+ sh $(TOPDIR)/scripts/ubinize-image.sh \
+ $(if $(UBOOTENV_IN_UBI),--uboot-env) \
+ $(if $(KERNEL_IN_UBI),--kernel $(IMAGE_KERNEL)) \
+ $(foreach part,$(UBINIZE_PARTS),--part $(part)) \
+ $(IMAGE_ROOTFS) \
+ $@.tmp \
+ -p $(BLOCKSIZE:%k=%KiB) -m $(PAGESIZE) \
+ $(if $(SUBPAGESIZE),-s $(SUBPAGESIZE)) \
+ $(if $(VID_HDR_OFFSET),-O $(VID_HDR_OFFSET)) \
+ $(UBINIZE_OPTS)
+ cat $@.tmp >> $@
+ rm $@.tmp
+endef
+
+define Build/append-uboot
+ dd if=$(UBOOT_PATH) >> $@
+endef
+
# append a fake/empty uImage header, to fool bootloaders rootfs integrity check
# for example
define Build/append-uImage-fakehdr
@@ -126,38 +113,51 @@ define Build/append-uImage-fakehdr
cat $@.fakehdr >> $@
endef
-define Build/tplink-safeloader
- -$(STAGING_DIR_HOST)/bin/tplink-safeloader \
- -B $(TPLINK_BOARD_ID) \
- -V $(REVISION) \
- -k $(IMAGE_KERNEL) \
- -r $@ \
- -o $@.new \
- -j \
- $(wordlist 2,$(words $(1)),$(1)) \
- $(if $(findstring sysupgrade,$(word 1,$(1))),-S) && mv $@.new $@ || rm -f $@
+define Build/buffalo-dhp-image
+ $(STAGING_DIR_HOST)/bin/mkdhpimg $@ $@.new
+ mv $@.new $@
endef
-define Build/append-dtb
- cat $(KDIR)/image-$(firstword $(DEVICE_DTS)).dtb >> $@
+define Build/buffalo-enc
+ $(eval product=$(word 1,$(1)))
+ $(eval version=$(word 2,$(1)))
+ $(eval args=$(wordlist 3,$(words $(1)),$(1)))
+ $(STAGING_DIR_HOST)/bin/buffalo-enc \
+ -p $(product) -v $(version) $(args) \
+ -i $@ -o $@.new
+ mv $@.new $@
endef
-define Build/append-dtb-elf
- $(TARGET_CROSS)objcopy \
- --set-section-flags=.appended_dtb=alloc,contents \
- --update-section \
- .appended_dtb=$(KDIR)/image-$(firstword $(DEVICE_DTS)).dtb $@
+define Build/buffalo-enc-tag
+ $(call Build/buffalo-enc,'' '' -S 152 $(1))
endef
-define Build/install-dtb
- $(call locked, \
- $(foreach dts,$(DEVICE_DTS), \
- $(CP) \
- $(DTS_DIR)/$(dts).dtb \
- $(BIN_DIR)/$(IMG_PREFIX)-$(dts).dtb; \
- ), \
- install-dtb-$(IMG_PREFIX) \
- )
+define Build/buffalo-tag-dhp
+ $(eval product=$(word 1,$(1)))
+ $(eval region=$(word 2,$(1)))
+ $(eval language=$(word 3,$(1)))
+ $(STAGING_DIR_HOST)/bin/buffalo-tag \
+ -d 0x01000000 -w 1 \
+ -a $(BUFFALO_TAG_PLATFORM) \
+ -v $(BUFFALO_TAG_VERSION) -m $(BUFFALO_TAG_MINOR) \
+ -b $(product) -p $(product) \
+ -r $(region) -r $(region) -l $(language) \
+ -I $@ -o $@.new
+ mv $@.new $@
+endef
+
+define Build/check-size
+ @imagesize="$$(stat -c%s $@)"; \
+ limitsize="$$(($(subst k,* 1024,$(subst m, * 1024k,$(if $(1),$(1),$(IMAGE_SIZE))))))"; \
+ [ $$limitsize -ge $$imagesize ] || { \
+ echo "WARNING: Image file $@ is too big: $$imagesize > $$limitsize" >&2; \
+ rm -f $@; \
+ }
+endef
+
+define Build/eva-image
+ $(STAGING_DIR_HOST)/bin/lzma2eva $(KERNEL_LOADADDR) $(KERNEL_LOADADDR) $@ $@.new
+ mv $@.new $@
endef
define Build/fit
@@ -172,28 +172,20 @@ define Build/fit
@mv $@.new $@
endef
-define Build/lzma
- $(call Build/lzma-no-dict,-lc1 -lp2 -pb2 $(1))
-endef
-
-define Build/lzma-no-dict
- $(STAGING_DIR_HOST)/bin/lzma e $@ $(1) $@.new
- @mv $@.new $@
-endef
-
define Build/gzip
gzip -f -9n -c $@ $(1) > $@.new
@mv $@.new $@
endef
-define Build/zip
- mkdir $@.tmp
- mv $@ $@.tmp/$(1)
-
- zip -j -X \
- $(if $(SOURCE_DATE_EPOCH),--mtime="$(SOURCE_DATE_EPOCH)") \
- $@ $@.tmp/$(if $(1),$(1),$@)
- rm -rf $@.tmp
+define Build/install-dtb
+ $(call locked, \
+ $(foreach dts,$(DEVICE_DTS), \
+ $(CP) \
+ $(DTS_DIR)/$(dts).dtb \
+ $(BIN_DIR)/$(IMG_PREFIX)-$(dts).dtb; \
+ ), \
+ install-dtb-$(IMG_PREFIX) \
+ )
endef
define Build/jffs2
@@ -211,55 +203,67 @@ define Build/jffs2
@mv $@.new $@
endef
+define Build/kernel2minor
+ kernel2minor -k $@ -r $@.new $(1)
+ mv $@.new $@
+endef
+
define Build/kernel-bin
rm -f $@
cp $< $@
endef
-define Build/patch-cmdline
- $(STAGING_DIR_HOST)/bin/patch-cmdline $@ '$(CMDLINE)'
+define Build/linksys-image
+ $(TOPDIR)/scripts/linksys-image.sh \
+ "$(call param_get_default,type,$(1),$(DEVICE_NAME))" \
+ $@ $@.new
+ mv $@.new $@
endef
-define Build/append-kernel
- dd if=$(IMAGE_KERNEL) >> $@
+define Build/lzma
+ $(call Build/lzma-no-dict,-lc1 -lp2 -pb2 $(1))
endef
-define Build/append-rootfs
- dd if=$(IMAGE_ROOTFS) >> $@
+define Build/lzma-no-dict
+ $(STAGING_DIR_HOST)/bin/lzma e $@ $(1) $@.new
+ @mv $@.new $@
endef
-define Build/append-ubi
- sh $(TOPDIR)/scripts/ubinize-image.sh \
- $(if $(UBOOTENV_IN_UBI),--uboot-env) \
- $(if $(KERNEL_IN_UBI),--kernel $(IMAGE_KERNEL)) \
- $(foreach part,$(UBINIZE_PARTS),--part $(part)) \
- $(IMAGE_ROOTFS) \
- $@.tmp \
- -p $(BLOCKSIZE:%k=%KiB) -m $(PAGESIZE) \
- $(if $(SUBPAGESIZE),-s $(SUBPAGESIZE)) \
- $(if $(VID_HDR_OFFSET),-O $(VID_HDR_OFFSET)) \
- $(UBINIZE_OPTS)
- cat $@.tmp >> $@
- rm $@.tmp
+define Build/netgear-chk
+ $(STAGING_DIR_HOST)/bin/mkchkimg \
+ -o $@.new \
+ -k $@ \
+ -b $(NETGEAR_BOARD_ID) \
+ $(if $(NETGEAR_REGION),-r $(NETGEAR_REGION),)
+ mv $@.new $@
endef
-define Build/append-uboot
- dd if=$(UBOOT_PATH) >> $@
+define Build/netgear-dni
+ $(STAGING_DIR_HOST)/bin/mkdniimg \
+ -B $(NETGEAR_BOARD_ID) -v $(VERSION_DIST).$(firstword $(subst -, ,$(REVISION))) \
+ $(if $(NETGEAR_HW_ID),-H $(NETGEAR_HW_ID)) \
+ -r "$(1)" \
+ -i $@ -o $@.new
+ mv $@.new $@
endef
-define Build/pad-to
- $(call Image/pad-to,$@,$(1))
+define Build/openmesh-image
+ $(TOPDIR)/scripts/om-fwupgradecfg-gen.sh \
+ "$(call param_get_default,ce_type,$(1),$(DEVICE_NAME))" \
+ "$@-fwupgrade.cfg" \
+ "$(call param_get_default,kernel,$(1),$(IMAGE_KERNEL))" \
+ "$(call param_get_default,rootfs,$(1),$@)"
+ $(TOPDIR)/scripts/combined-ext-image.sh \
+ "$(call param_get_default,ce_type,$(1),$(DEVICE_NAME))" "$@" \
+ "$@-fwupgrade.cfg" "fwupgrade.cfg" \
+ "$(call param_get_default,kernel,$(1),$(IMAGE_KERNEL))" "kernel" \
+ "$(call param_get_default,rootfs,$(1),$@)" "rootfs"
endef
define Build/pad-extra
dd if=/dev/zero bs=$(1) count=1 >> $@
endef
-define Build/pad-rootfs
- $(STAGING_DIR_HOST)/bin/padjffs2 $@ $(1) \
- $(if $(BLOCKSIZE),$(BLOCKSIZE:%k=%),4 8 16 64 128 256)
-endef
-
define Build/pad-offset
let \
size="$$(stat -c%s $@)" \
@@ -271,38 +275,24 @@ define Build/pad-offset
mv $@.new $@
endef
-define Build/xor-image
- $(STAGING_DIR_HOST)/bin/xorimage -i $@ -o $@.xor $(1)
- mv $@.xor $@
+define Build/pad-rootfs
+ $(STAGING_DIR_HOST)/bin/padjffs2 $@ $(1) \
+ $(if $(BLOCKSIZE),$(BLOCKSIZE:%k=%),4 8 16 64 128 256)
endef
-define Build/check-size
- @imagesize="$$(stat -c%s $@)"; \
- limitsize="$$(($(subst k,* 1024,$(subst m, * 1024k,$(if $(1),$(1),$(IMAGE_SIZE))))))"; \
- [ $$limitsize -ge $$imagesize ] || { \
- echo "WARNING: Image file $@ is too big: $$imagesize > $$limitsize" >&2; \
- rm -f $@; \
- }
+define Build/pad-to
+ $(call Image/pad-to,$@,$(1))
endef
-define Build/linksys-image
- $(TOPDIR)/scripts/linksys-image.sh \
- "$(call param_get_default,type,$(1),$(DEVICE_NAME))" \
- $@ $@.new
- mv $@.new $@
+define Build/patch-cmdline
+ $(STAGING_DIR_HOST)/bin/patch-cmdline $@ '$(CMDLINE)'
endef
-define Build/openmesh-image
- $(TOPDIR)/scripts/om-fwupgradecfg-gen.sh \
- "$(call param_get_default,ce_type,$(1),$(DEVICE_NAME))" \
- "$@-fwupgrade.cfg" \
- "$(call param_get_default,kernel,$(1),$(IMAGE_KERNEL))" \
- "$(call param_get_default,rootfs,$(1),$@)"
- $(TOPDIR)/scripts/combined-ext-image.sh \
- "$(call param_get_default,ce_type,$(1),$(DEVICE_NAME))" "$@" \
- "$@-fwupgrade.cfg" "fwupgrade.cfg" \
- "$(call param_get_default,kernel,$(1),$(IMAGE_KERNEL))" "kernel" \
- "$(call param_get_default,rootfs,$(1),$@)" "rootfs"
+# Convert a raw image into a $1 type image.
+# E.g. | qemu-image vdi
+define Build/qemu-image
+ qemu-img convert -f raw -O $1 $@ $@.new
+ @mv $@.new $@
endef
define Build/qsdk-ipq-factory-nand
@@ -319,6 +309,18 @@ define Build/qsdk-ipq-factory-nor
@mv $@.new $@
endef
+define Build/seama
+ $(STAGING_DIR_HOST)/bin/seama -i $@ \
+ -m "dev=/dev/mtdblock/$(SEAMA_MTDBLOCK)" -m "type=firmware"
+ mv $@.seama $@
+endef
+
+define Build/seama-seal
+ $(STAGING_DIR_HOST)/bin/seama -i $@ -s $@.seama \
+ -m "signature=$(SEAMA_SIGNATURE)"
+ mv $@.seama $@
+endef
+
define Build/senao-header
$(STAGING_DIR_HOST)/bin/mksenaofw $(1) -e $@ -o $@.new
mv $@.new $@
@@ -332,6 +334,18 @@ define Build/sysupgrade-tar
$@
endef
+define Build/tplink-safeloader
+ -$(STAGING_DIR_HOST)/bin/tplink-safeloader \
+ -B $(TPLINK_BOARD_ID) \
+ -V $(REVISION) \
+ -k $(IMAGE_KERNEL) \
+ -r $@ \
+ -o $@.new \
+ -j \
+ $(wordlist 2,$(words $(1)),$(1)) \
+ $(if $(findstring sysupgrade,$(word 1,$(1))),-S) && mv $@.new $@ || rm -f $@
+endef
+
define Build/tplink-v1-header
$(STAGING_DIR_HOST)/bin/mktplinkfw \
-c -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -L $(KERNEL_LOADADDR) \
@@ -379,51 +393,38 @@ define Build/tplink-v2-image
rm -rf $@.new
endef
-compat_version=$(if $(DEVICE_COMPAT_VERSION),$(DEVICE_COMPAT_VERSION),1.0)
-json_quote=$(subst ','\'',$(subst ",\",$(1)))
-#")')
-
-legacy_supported_message=$(SUPPORTED_DEVICES) - Image version mismatch: image $(compat_version), \
- device 1.0. Please wipe config during upgrade (force required) or reinstall. \
- $(if $(DEVICE_COMPAT_MESSAGE),Reason: $(DEVICE_COMPAT_MESSAGE),Please check documentation ...)
-
-metadata_devices=$(if $(1),$(subst "$(space)","$(comma)",$(strip $(foreach v,$(1),"$(call json_quote,$(v))"))))
-metadata_json = \
- '{ $(if $(IMAGE_METADATA),$(IMAGE_METADATA)$(comma)) \
- "metadata_version": "1.1", \
- "compat_version": "$(call json_quote,$(compat_version))", \
- $(if $(DEVICE_COMPAT_MESSAGE),"compat_message": "$(call json_quote,$(DEVICE_COMPAT_MESSAGE))"$(comma)) \
- $(if $(filter-out 1.0,$(compat_version)),"new_supported_devices": \
- [$(call metadata_devices,$(SUPPORTED_DEVICES))]$(comma) \
- "supported_devices": ["$(call json_quote,$(legacy_supported_message))"]$(comma)) \
- $(if $(filter 1.0,$(compat_version)),"supported_devices":[$(call metadata_devices,$(SUPPORTED_DEVICES))]$(comma)) \
- "version": { \
- "dist": "$(call json_quote,$(VERSION_DIST))", \
- "version": "$(call json_quote,$(VERSION_NUMBER))", \
- "revision": "$(call json_quote,$(REVISION))", \
- "target": "$(call json_quote,$(TARGETID))", \
- "board": "$(call json_quote,$(if $(BOARD_NAME),$(BOARD_NAME),$(DEVICE_NAME)))" \
- } \
- }'
+define Build/uImage
+ mkimage -A $(LINUX_KARCH) \
+ -O linux -T kernel \
+ -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+ -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' -d $@ $@.new
+ mv $@.new $@
+endef
-define Build/append-metadata
- $(if $(SUPPORTED_DEVICES),-echo $(call metadata_json) | fwtool -I - $@)
- [ ! -s "$(BUILD_KEY)" -o ! -s "$(BUILD_KEY).ucert" -o ! -s "$@" ] || { \
- cp "$(BUILD_KEY).ucert" "$@.ucert" ;\
- usign -S -m "$@" -s "$(BUILD_KEY)" -x "$@.sig" ;\
- ucert -A -c "$@.ucert" -x "$@.sig" ;\
- fwtool -S "$@.ucert" "$@" ;\
- }
+define Build/xor-image
+ $(STAGING_DIR_HOST)/bin/xorimage -i $@ -o $@.xor $(1)
+ mv $@.xor $@
endef
-define Build/kernel2minor
- kernel2minor -k $@ -r $@.new $(1)
- mv $@.new $@
+define Build/zip
+ mkdir $@.tmp
+ mv $@ $@.tmp/$(1)
+
+ zip -j -X \
+ $(if $(SOURCE_DATE_EPOCH),--mtime="$(SOURCE_DATE_EPOCH)") \
+ $@ $@.tmp/$(if $(1),$(1),$@)
+ rm -rf $@.tmp
endef
-# Convert a raw image into a $1 type image.
-# E.g. | qemu-image vdi
-define Build/qemu-image
- qemu-img convert -f raw -O $1 $@ $@.new
- @mv $@.new $@
+define Build/zyxel-ras-image
+ let \
+ newsize="$(subst k,* 1024,$(RAS_ROOTFS_SIZE))"; \
+ $(STAGING_DIR_HOST)/bin/mkrasimage \
+ -b $(RAS_BOARD) \
+ -v $(RAS_VERSION) \
+ -r $@ \
+ -s $$newsize \
+ -o $@.new \
+ $(if $(findstring separate-kernel,$(word 1,$(1))),-k $(IMAGE_KERNEL)) \
+ && mv $@.new $@
endef