aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorIan Pozella <Ian.Pozella@imgtec.com>2016-09-26 15:06:10 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-13 14:54:11 +0100
commit859693509f33a90c3eae29190b6f7b7533a5fff0 (patch)
tree63bd7ae25041b9819f9359aa88a43d34a1aa6e69 /include/image-commands.mk
parentf44663c673f5412ce679f3c6e0f1b6b17b6f0c22 (diff)
downloadupstream-859693509f33a90c3eae29190b6f7b7533a5fff0.tar.gz
upstream-859693509f33a90c3eae29190b6f7b7533a5fff0.tar.bz2
upstream-859693509f33a90c3eae29190b6f7b7533a5fff0.zip
image.mk: use LINUX_KARCH rather than ARCH for mkits
The generated 'its' is passed to mkimage which expects linux arch strings rather than the full arch (e.g. mips not mipsel). It currently works in some cases where LINUX_KARCH == ARCH but otherwise you get an unknown arch build error. Signed-off-by: Ian Pozella <Ian.Pozella@imgtec.com> Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index a7acd0ee67..04fa853fbb 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -59,7 +59,7 @@ define Build/fit
-D $(DEVICE_NAME) -o $@.its -k $@ \
$(if $(word 2,$(1)),-d $(word 2,$(1))) -C $(word 1,$(1)) \
-a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -A $(ARCH) -v $(LINUX_VERSION)
+ -A $(LINUX_KARCH) -v $(LINUX_VERSION)
PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $@.its $@.new
@mv $@.new $@
endef