aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2019-03-06 00:32:45 +0100
committerDaniel Golle <daniel@makrotopia.org>2019-03-06 01:11:54 +0100
commit7fa9794c4ce5988c8ef483d6f402033bf08eabb3 (patch)
tree486b03213a639a63b5fbddffd2f03e4cf6a020a9 /include/image-commands.mk
parent208f287908e4143170417ce6cda9ca6c287ccc90 (diff)
downloadupstream-7fa9794c4ce5988c8ef483d6f402033bf08eabb3.tar.gz
upstream-7fa9794c4ce5988c8ef483d6f402033bf08eabb3.tar.bz2
upstream-7fa9794c4ce5988c8ef483d6f402033bf08eabb3.zip
metadata: add "metadata_version" field
allow downstream projects to see the current version of the metadata, usefull if eventually more variables change Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index c0bda2084c..8251a81400 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -355,6 +355,7 @@ json_quote=$(subst ','\'',$(subst ",\",$(1)))
metadata_devices=$(if $(1),$(subst "$(space)","$(comma)",$(strip $(foreach v,$(1),"$(call json_quote,$(v))"))))
metadata_json = \
'{ $(if $(IMAGE_METADATA),$(IMAGE_METADATA)$(comma)) \
+ "metadata_version": "1.0", \
"supported_devices":[$(call metadata_devices,$(1))], \
"version": { \
"dist": "$(call json_quote,$(VERSION_DIST))", \