aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-21 16:39:56 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-22 16:42:20 +0100
commitffb0181a8731847ea0d02d6e158adf3d7d95c382 (patch)
treecb7194bddf4b8983598829102a4e239f28e1bc7f /include/host-build.mk
parent24e58c3f72a94ebf659586eb876b06b59adb2bb2 (diff)
downloadupstream-ffb0181a8731847ea0d02d6e158adf3d7d95c382.tar.gz
upstream-ffb0181a8731847ea0d02d6e158adf3d7d95c382.tar.bz2
upstream-ffb0181a8731847ea0d02d6e158adf3d7d95c382.zip
build: add defaults for PKG_SOURCE, PKG_SOURCE_SUBDIR, PKG_VERSION
This makes it easier to unify versioning of git based package downloads. PKG_SOURCE_DATE along with an 8-character abbreviation of the git hash is used as PKG_VERSION, PKG_RELEASE should be used like normal packages. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index e11e3edd09..f6ca3ff21e 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -5,6 +5,8 @@
# See /LICENSE for more information.
#
+include $(INCLUDE_DIR)/download.mk
+
HOST_BUILD_DIR ?= $(BUILD_DIR_HOST)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
HOST_INSTALL_DIR ?= $(HOST_BUILD_DIR)/host-install
HOST_BUILD_PARALLEL ?=
@@ -35,7 +37,6 @@ HOST_STAMP_INSTALLED:=$(HOST_BUILD_PREFIX)/stamp/.$(PKG_NAME)_installed
override MAKEFLAGS=
-include $(INCLUDE_DIR)/download.mk
include $(INCLUDE_DIR)/quilt.mk
include $(INCLUDE_DIR)/autotools.mk