aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorSven Wegener <sven.wegener@stealer.net>2020-12-27 11:47:45 +0100
committerPaul Spooren <mail@aparcar.org>2021-01-01 10:29:07 -1000
commite9fb9b79f62f7d1224a2c88b5b88969a2442d56a (patch)
tree3cb4805af3e687813f8900ef2713eb77cb84505c /include/host-build.mk
parent5eaf6d8bead2f1313d2e19ae485fcb008bfc073a (diff)
downloadupstream-e9fb9b79f62f7d1224a2c88b5b88969a2442d56a.tar.gz
upstream-e9fb9b79f62f7d1224a2c88b5b88969a2442d56a.tar.bz2
upstream-e9fb9b79f62f7d1224a2c88b5b88969a2442d56a.zip
build: drop ccache variables from specific targets
With commit 2ca084cc ("build: improve ccache support") these variables are being set globally and we don't need them for specific targets. Signed-off-by: Sven Wegener <sven.wegener@stealer.net>
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk3
1 files changed, 0 insertions, 3 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 4ac1405181..ab6e05e14f 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -132,9 +132,6 @@ define Host/Exports/Default
$(1) : export STAGING_PREFIX=$$(HOST_BUILD_PREFIX)
$(1) : export PKG_CONFIG_PATH=$$(STAGING_DIR_HOST)/lib/pkgconfig:$$(HOST_BUILD_PREFIX)/lib/pkgconfig
$(1) : export PKG_CONFIG_LIBDIR=$$(HOST_BUILD_PREFIX)/lib/pkgconfig
- $(if $(CONFIG_CCACHE),$(1) : export CCACHE_BASEDIR:=$(TOPDIR))
- $(if $(CONFIG_CCACHE),$(1) : export CCACHE_DIR:=$(if $(call qstrip,$(CONFIG_CCACHE_DIR)),$(call qstrip,$(CONFIG_CCACHE_DIR)),$(TOPDIR)/.ccache))
- $(if $(CONFIG_CCACHE),$(1) : export CCACHE_COMPILERCHECK:=%compiler% -dumpmachine; %compiler% -dumpversion)
$(if $(HOST_CONFIG_SITE),$(1) : export CONFIG_SITE:=$(HOST_CONFIG_SITE))
$(if $(IS_PACKAGE_BUILD),$(1) : export PATH=$$(TARGET_PATH_PKG))
endef