aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-10-06 00:28:45 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-10-06 00:51:34 +0200
commitcb718eb34bc392bac8d91047d5bebf839fa6a2f5 (patch)
tree168c93be5ddd2bb57685fa0eac4af97a06ae9829 /include/host-build.mk
parent4ada2fd2768cba671c3289ce9eb8f5c9c728da1f (diff)
downloadupstream-cb718eb34bc392bac8d91047d5bebf839fa6a2f5.tar.gz
upstream-cb718eb34bc392bac8d91047d5bebf839fa6a2f5.tar.bz2
upstream-cb718eb34bc392bac8d91047d5bebf839fa6a2f5.zip
include/host-build.mk: set Host/Exports for Host/Install step
Having a different PATH in Host/Install than in other steps like Host/Build is confusing and easily leads to mistakes. Setting all of Host/Exports makes host builds match target builds (Build/Install is part of $(STAMP_BUILT), which has Build/Exports set). Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 688f8d8442..72b32597d4 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -172,6 +172,7 @@ ifndef DUMP
$(foreach hook,$(Hooks/HostCompile/Post),$(call $(hook))$(sep))
touch $$@
+ $(call Host/Exports,$(HOST_STAMP_INSTALLED))
$(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT) $(if $(FORCE_HOST_INSTALL),FORCE)
$(call Host/Install,$(HOST_BUILD_PREFIX))
$(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))