aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-10-06 00:02:21 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-10-06 00:19:18 +0200
commit7064a849ce3342428c8e120e225b6b45c58e95cd (patch)
tree20bbfdaaadc298ca5d96f868670d9a675b7275fb /include/host-build.mk
parent73c87a3cad3c77d581e46ef9707d175a0651351f (diff)
downloadupstream-7064a849ce3342428c8e120e225b6b45c58e95cd.tar.gz
upstream-7064a849ce3342428c8e120e225b6b45c58e95cd.tar.bz2
upstream-7064a849ce3342428c8e120e225b6b45c58e95cd.zip
include/host-build.mk: pass HOST_BUILD_PREFIX to Host/install
Using HOST_BUILD_PREFIX instead of STAGING_DIR_HOST will make the argument work as expected from packages. Nothing changes for tools, for which HOST_BUILD_PREFIX and STAGING_DIR_HOST are equivalent. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 659cdc4837..0b10c7cdf9 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -111,7 +111,7 @@ define Host/Install/Default
endef
define Host/Install
- $(call Host/Install/Default,$(STAGING_DIR_HOST))
+ $(call Host/Install/Default,$(HOST_BUILD_PREFIX))
endef
@@ -173,7 +173,7 @@ ifndef DUMP
touch $$@
$(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT) $(if $(FORCE_HOST_INSTALL),FORCE)
- $(call Host/Install,$(STAGING_DIR_HOST))
+ $(call Host/Install,$(HOST_BUILD_PREFIX))
$(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
mkdir -p $$(shell dirname $$@)
touch $(HOST_STAMP_BUILT)