aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-10-05 19:45:44 +0200
committerFelix Fietkau <nbd@nbd.name>2017-10-05 21:14:43 +0200
commit603900ef820d20d96a10032160bf6c67203b33e6 (patch)
tree7b2bbf06917cdd8aae20e30847fc30adb772df9f /include/host-build.mk
parent20f365d70f3d219fe808532fe5892ecb134dbc73 (diff)
downloadupstream-603900ef820d20d96a10032160bf6c67203b33e6.tar.gz
upstream-603900ef820d20d96a10032160bf6c67203b33e6.tar.bz2
upstream-603900ef820d20d96a10032160bf6c67203b33e6.zip
build: add a darwin sitefile to deal with macOS 10.12 + Xcode 9 build errors
Certain functions are available in system headers, but only work on macOS 10.13 Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index dc70373855..113e269b4c 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -78,6 +78,10 @@ HOST_MAKE_FLAGS =
HOST_CONFIGURE_CMD = $(BASH) ./configure
+ifeq ($(HOST_OS),Darwin)
+ HOST_CONFIG_SITE:=$(INCLUDE_DIR)/site/darwin
+endif
+
define Host/Configure/Default
$(if $(HOST_CONFIGURE_PARALLEL),+)(cd $(HOST_BUILD_DIR)/$(3); \
if [ -x configure ]; then \
@@ -128,6 +132,7 @@ define Host/Exports/Default
$(1) : export PKG_CONFIG_PATH=$$(STAGING_DIR_HOST)/lib/pkgconfig:$$(HOST_BUILD_PREFIX)/lib/pkgconfig
$(1) : export PKG_CONFIG_LIBDIR=$$(HOST_BUILD_PREFIX)/lib/pkgconfig
$(1) : export CCACHE_DIR:=$(STAGING_DIR_HOST)/ccache
+ $(if $(HOST_CONFIG_SITE),$(1) : export CONFIG_SITE:=$(HOST_CONFIG_SITE))
$(if $(IS_PACKAGE_BUILD),$(1) : export PATH=$$(TARGET_PATH_PKG))
endef
Host/Exports=$(Host/Exports/Default)