aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-11-19 16:32:46 +0100
committerPetr Štetiar <ynezz@true.cz>2020-11-27 14:46:13 +0100
commit4e19cbc553350b8146985367ba46514cf50e3393 (patch)
tree56e074dba71b22fabb938c74061f1cd44520354b /include/host-build.mk
parent9762cf107bdbd709717b8adbba6f987c9935c74f (diff)
downloadupstream-4e19cbc553350b8146985367ba46514cf50e3393.tar.gz
upstream-4e19cbc553350b8146985367ba46514cf50e3393.tar.bz2
upstream-4e19cbc553350b8146985367ba46514cf50e3393.zip
download: handle possibly invalid local tarballs
Currently it's assumed, that already downloaded tarballs are always fine, so no checksum checking is performed and the tarball is used even if it might be corrupted. From now on, we're going to always check the downloaded tarballs before considering them valid. Steps to reproduce: 1. Remove cached tarball rm dl/libubox-2020-08-06-9e52171d.tar.xz 2. Download valid tarball again make package/libubox/download 3. Invalidate the tarball sed -i 's/PKG_MIRROR_HASH:=../PKG_MIRROR_HASH:=ff/' package/libs/libubox/Makefile 4. Now compile with corrupt tarball source make package/libubox/{clean,compile} Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 7d84ab0f5f..4ac1405181 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -186,6 +186,8 @@ ifndef DUMP
clean-build: host-clean-build
endif
+ $(DL_DIR)/$(FILE): FORCE
+
$(_host_target)host-prepare: $(HOST_STAMP_PREPARED)
$(_host_target)host-configure: $(HOST_STAMP_CONFIGURED)
$(_host_target)host-compile: $(HOST_STAMP_BUILT) $(HOST_STAMP_INSTALLED)