aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-26 18:04:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-26 18:04:16 +0000
commit2dcaf582db6426bfaf995f9427cdefce26a3e634 (patch)
tree31ef8fcba317d3a164170e1106aa21d773d70777 /include/host-build.mk
parent3efafd390f1b7518e38cb91cca0b3d991ce7e00e (diff)
downloadupstream-2dcaf582db6426bfaf995f9427cdefce26a3e634.tar.gz
upstream-2dcaf582db6426bfaf995f9427cdefce26a3e634.tar.bz2
upstream-2dcaf582db6426bfaf995f9427cdefce26a3e634.zip
Small bugfix for dependency handling - mostly for base-files and symlinks
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7058 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 13bd162520..591a36bd38 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -80,7 +80,7 @@ endif
ifneq ($(CONFIG_AUTOREBUILD),)
define HostBuild/Autoclean
$(PKG_BUILD_DIR)/.dep_files: $(STAMP_PREPARED)
- $(call rdep,${CURDIR},$(STAMP_PREPARED),$(TMP_DIR)/.packagedir_$(shell echo "${CURDIR}" | md5s))
+ $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED),$(TMP_DIR)/.packagedir_$(shell echo "${CURDIR}" | md5s))
$(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),$(PKG_BUILD_DIR)/.dep_files, -and -not -path "/.*" -and -not -path "*/ipkg*")
endef
endif