aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-22 17:40:29 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-22 17:40:31 +0100
commit0e22d6377569cea4ba00b81d6ec64a1582a2cea4 (patch)
tree894de324de0abaf69607830fb5cebea34f1c12d6 /include/host-build.mk
parent34ec245662766354ce0d19d586bb08f220ddb3b3 (diff)
downloadupstream-0e22d6377569cea4ba00b81d6ec64a1582a2cea4.tar.gz
upstream-0e22d6377569cea4ba00b81d6ec64a1582a2cea4.tar.bz2
upstream-0e22d6377569cea4ba00b81d6ec64a1582a2cea4.zip
build: fix CONFIG_AUTOREMOVE for packages with multiple variants
Calling the clean target removes all .ipk files and un-stages the package. Add a new target just for clearing the build dir and call that one instead of the full clean target Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk9
1 files changed, 7 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 6a335fcbc3..d96cc94fa3 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -176,15 +176,20 @@ ifndef DUMP
$(t): host-$(t)
.$(t): .host-$(t)
)
+ clean-build: host-clean-build
endif
$(_host_target)host-prepare: $(HOST_STAMP_PREPARED)
$(_host_target)host-configure: $(HOST_STAMP_CONFIGURED)
$(_host_target)host-compile: $(HOST_STAMP_BUILT) $(HOST_STAMP_INSTALLED)
- host-clean: FORCE
+
+ host-clean-build: FORCE
+ rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_BUILT)
+
+ host-clean: host-clean-build
$(call Host/Clean)
$(call Host/Uninstall)
- rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_INSTALLED) $(HOST_STAMP_BUILT)
+ rm -rf $(HOST_STAMP_INSTALLED)
ifneq ($(CONFIG_AUTOREMOVE),)
host-compile: