aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2019-09-28 13:10:59 +0200
committerJohn Crispin <john@phrozen.org>2019-10-21 14:18:17 +0200
commit02330a655676bbb0432e5fc30bfe7fdd21a9c9c9 (patch)
tree37636430d3c0029326c086909d024cf1cb2e8427 /include/host-build.mk
parent53e6cc7a81175728f64f978c2363a18c1fa66d64 (diff)
downloadupstream-02330a655676bbb0432e5fc30bfe7fdd21a9c9c9.tar.gz
upstream-02330a655676bbb0432e5fc30bfe7fdd21a9c9c9.tar.bz2
upstream-02330a655676bbb0432e5fc30bfe7fdd21a9c9c9.zip
build: call Host/Uninstall before wiping the host build dir
Uninstall targets may depend on build artefacts, like `make uninstall` or `ninja uninstall`. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 827ea6bbfb..9fc14241c6 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -190,11 +190,11 @@ ifndef DUMP
host-install: host-compile
host-clean-build: FORCE
+ $(call Host/Uninstall)
rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_BUILT)
host-clean: host-clean-build
$(call Host/Clean)
- $(call Host/Uninstall)
rm -rf $(HOST_STAMP_INSTALLED)
ifneq ($(CONFIG_AUTOREMOVE),)