aboutsummaryrefslogtreecommitdiffstats
path: root/include/feeds.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-02-12 11:16:35 +0100
committerFelix Fietkau <nbd@nbd.name>2021-02-14 19:41:52 +0100
commitc92165038217e49075098479704da58a2a3a89bd (patch)
treeb5b6d843dc3d09c7c5074da3f20aaf8c8964837e /include/feeds.mk
parentf421fefa8a34319c5ff5dcc1af39d6311ec1ad1e (diff)
downloadupstream-c92165038217e49075098479704da58a2a3a89bd.tar.gz
upstream-c92165038217e49075098479704da58a2a3a89bd.tar.bz2
upstream-c92165038217e49075098479704da58a2a3a89bd.zip
build: drop ABI version from metadata
Preparation for supporting dynamic ABI versions that depend on the runtime configuration. Read the suffix from the staging dir pkginfo version files. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/feeds.mk')
-rw-r--r--include/feeds.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index ef5fef7f4b..5676cc4a8f 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -43,5 +43,5 @@ endef
# 1: package name
define GetABISuffix
-$(if $(filter-out kmod-%,$(1)),$(if $(Package/$(1)/abiversion),$(if $(filter %0 %1 %2 %3 %4 %5 %6 %7 %8 %9,$(1)),-)$(Package/$(1)/abiversion)))
+$(if $(filter-out kmod-%,$(1)),$(foreach v,$(wildcard $(STAGING_DIR)/pkginfo/$(1).version),$(shell cat $(v))))
endef