aboutsummaryrefslogtreecommitdiffstats
path: root/include/feeds.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2021-06-14 14:58:37 +0200
committerJo-Philipp Wich <jo@mein.io>2021-07-11 16:09:30 +0200
commit47f617ef8d44e4d7428ff3e0b42acb4a75f5cd37 (patch)
tree0c77381969347440193feba1b1175b7e3a9d37c5 /include/feeds.mk
parentfebf6db0d02c1bdadd4db621a0070b80eb94b7fb (diff)
downloadupstream-47f617ef8d44e4d7428ff3e0b42acb4a75f5cd37.tar.gz
upstream-47f617ef8d44e4d7428ff3e0b42acb4a75f5cd37.tar.bz2
upstream-47f617ef8d44e4d7428ff3e0b42acb4a75f5cd37.zip
build: prepend ABI suffixes with a dash if package name ends with digit
Ensure that ABI suffixes are separated with a dash from the package name if the name happens to end with a digit. This implementation detail got lost during the recent refactoring of the ABI_VERSION handling in buildroot. Ref: https://github.com/openwrt/packages/pull/14237#issuecomment-860473585 Fixes: c921650382 ("build: drop ABI version from metadata") Signed-off-by: Jo-Philipp Wich <jo@mein.io> (cherry picked from commit f6a03bff5bccdbf9165087bccbb35095903d05c6)
Diffstat (limited to 'include/feeds.mk')
-rw-r--r--include/feeds.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index 98e315bceb..e499ac2684 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -43,5 +43,11 @@ endef
# 1: package name
define GetABISuffix
-$(if $(filter-out kmod-%,$(1)),$(if $(ABIV_$(1)),$(ABIV_$(1)),$(foreach v,$(wildcard $(STAGING_DIR)/pkginfo/$(1).version),$(shell cat $(v)))))
+$(call FormatABISuffix,$(1),$(if $(ABIV_$(1)),$(ABIV_$(1)),$(foreach v,$(wildcard $(STAGING_DIR)/pkginfo/$(1).version),$(shell cat $(v)))))
+endef
+
+# 1: package name
+# 2: abi version
+define FormatABISuffix
+$(if $(filter-out kmod-%,$(1)),$(if $(2),$(if $(filter %0 %1 %2 %3 %4 %5 %6 %7 %8 %9,$(1)),-)$(2)))
endef