aboutsummaryrefslogtreecommitdiffstats
path: root/include/feeds.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-09-15 12:33:46 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-10-30 00:39:09 +0000
commit071514c6419151674d50a4607dc09303f54014ce (patch)
tree43d52f0f115b4bf079558da7114a88365ce4b7d5 /include/feeds.mk
parent7f94e2afcf090f751c9f7f7ea46e8ef8d93ee84b (diff)
downloadupstream-071514c6419151674d50a4607dc09303f54014ce.tar.gz
upstream-071514c6419151674d50a4607dc09303f54014ce.tar.bz2
upstream-071514c6419151674d50a4607dc09303f54014ce.zip
build: FeedSourcesAppend add kmod feed to snapshot
Nightly snapshot builds of OpenWrt change their kernels versions frequently and lose thereby compatibility to kmods from the upstream target specific packages feed. To allow opkg to install packages over multiple days a kmod archive is offered at $target/$subtarget/kmods/$kernelversion and added as a feed to created snapshot images via a buildbot step[1]. Instead of using a buildstep add the kmod feed directly via FeedSourcesAppend to be included in the ImageBuilder repositories.conf as well. This is conditionally only done for SNAPSHOT builds and when running as BUILDBOT. Releases are unaffected as they don't include kernel version changes and local builds may use different kernel versions or magics than available upstream. This commit allows in a future step to ship ImageBuilders without a locally stored kmod archive. [1]: https://git.openwrt.org/?p=buildbot.git;a=blob;f=phase1/master.cfg;h=3ba7a1606e89b095b10555e703ea96e93295deec;hb=HEAD#l1025 Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include/feeds.mk')
-rw-r--r--include/feeds.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index 9637424c5b..2b259b96b3 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -36,6 +36,8 @@ define FeedSourcesAppend
echo 'src/gz %d_core %U/targets/%S/packages'; \
$(strip $(if $(CONFIG_PER_FEED_REPO), \
echo 'src/gz %d_base %U/packages/%A/base'; \
+ $(if $(filter %SNAPSHOT-y,$(VERSION_NUMBER)-$(CONFIG_BUILDBOT)), \
+ echo 'src/gz %d_kmods %U/targets/%S/kmods/$(LINUX_VERSION)-$(LINUX_RELEASE)-$(LINUX_VERMAGIC)';) \
$(foreach feed,$(FEEDS_AVAILABLE), \
$(if $(CONFIG_FEED_$(feed)), \
echo '$(if $(filter m,$(CONFIG_FEED_$(feed))),# )src/gz %d_$(feed) %U/packages/%A/$(feed)';)))) \