aboutsummaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-16 15:26:22 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-16 15:35:21 +0100
commit881c5b47ece3702ee9ea6fe450cded8635da5056 (patch)
tree56a6cf93b898584a0b176e93a31371060aaeb32c /include/download.mk
parent651bc94df424faae586f0ad8ca0f0a4ef95e5090 (diff)
downloadupstream-881c5b47ece3702ee9ea6fe450cded8635da5056.tar.gz
upstream-881c5b47ece3702ee9ea6fe450cded8635da5056.tar.bz2
upstream-881c5b47ece3702ee9ea6fe450cded8635da5056.zip
build: remove duplicate Download/default definition from include/host-build.mk
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/include/download.mk b/include/download.mk
index 0a12c69ebd..ec55777238 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -180,6 +180,19 @@ define Download/Defaults
OPTS:=
endef
+define Download/default
+ FILE:=$(PKG_SOURCE)
+ URL:=$(PKG_SOURCE_URL)
+ SUBDIR:=$(PKG_SOURCE_SUBDIR)
+ PROTO:=$(PKG_SOURCE_PROTO)
+ $(if $(PKG_SOURCE_MIRROR),MIRROR:=$(filter 1,$(PKG_MIRROR)))
+ $(if $(PKG_MIRROR_MD5SUM),MIRROR_MD5SUM:=$(PKG_MIRROR_MD5SUM))
+ $(if $(PKG_MIRROR_HASH),MIRROR_HASH:=$(PKG_MIRROR_HASH))
+ VERSION:=$(PKG_SOURCE_VERSION)
+ $(if $(PKG_MD5SUM),MD5SUM:=$(PKG_MD5SUM))
+ $(if $(PKG_HASH),HASH:=$(PKG_HASH))
+endef
+
define Download
$(eval $(Download/Defaults))
$(eval $(Download/$(1)))