aboutsummaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2019-03-28 16:58:07 +0000
committerChristian Lamparter <chunkeey@gmail.com>2019-04-06 19:14:06 +0200
commit8252511dc0b5a71e9e64b96f233a27ad73e28b7f (patch)
tree8d288804fad7442e2b74f49f7d906999d4f418e6 /include/download.mk
parent32a6c252dbcf91c567031ef6175a7d008e492088 (diff)
downloadupstream-8252511dc0b5a71e9e64b96f233a27ad73e28b7f.tar.gz
upstream-8252511dc0b5a71e9e64b96f233a27ad73e28b7f.tar.bz2
upstream-8252511dc0b5a71e9e64b96f233a27ad73e28b7f.zip
build: remove sgid permission from tar
Otherwise tar will keep the sgid bit when running from a sgid-set directory, resulting in a different file being generated. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [reworked commit message, removed DMARC]
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 33141910fc..09794e155e 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -55,7 +55,8 @@ define dl_pack
$(if $(dl_pack/$(call ext,$(1))),$(dl_pack/$(call ext,$(1))),$(dl_pack/unknown))
endef
define dl_tar_pack
- $(TAR) --numeric-owner --owner=0 --group=0 --sort=name $$$${TAR_TIMESTAMP:+--mtime="$$$$TAR_TIMESTAMP"} -c $(2) | $(call dl_pack,$(1))
+ $(TAR) --numeric-owner --owner=0 --group=0 --mode=a-s --sort=name \
+ $$$${TAR_TIMESTAMP:+--mtime="$$$$TAR_TIMESTAMP"} -c $(2) | $(call dl_pack,$(1))
endef
ifdef CHECK