aboutsummaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorKamil Wcislo <kamil.wcislo@lpnplant.io>2018-07-05 21:40:19 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2019-11-23 13:35:43 +0100
commit09c428ec6bca27bdb31e2f6fef85b07787cead30 (patch)
treea965080de994f8c0fc39ca4164bc8ebe39ef9224 /include/download.mk
parent226bc91109c814b3577b1b126f4ab420c868d5a8 (diff)
downloadupstream-09c428ec6bca27bdb31e2f6fef85b07787cead30.tar.gz
upstream-09c428ec6bca27bdb31e2f6fef85b07787cead30.tar.bz2
upstream-09c428ec6bca27bdb31e2f6fef85b07787cead30.zip
build: add PKG_SOURCE_URL_FILE support
It seems that there is a missing PKG_SOURCE_URL_FILE support. This little fix adds the support for packages to change the name of the downloaded file. Sometimes it is desirable to change the downloaded archive file name, like for mitigating name conflicts for different packages (some files on the server could be named like, e.g. 2018-01-01.tar.gz) or for the cases that there is no name for the file in the URL (e.g. http://someserver.com/download). Signed-off-by: Kamil Wcislo <kamil.wcislo@lpnplant.io> Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/download.mk b/include/download.mk
index 09794e155e..14d68bf8f5 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -289,6 +289,7 @@ endef
define Download/default
FILE:=$(PKG_SOURCE)
URL:=$(PKG_SOURCE_URL)
+ URL_FILE:=$(PKG_SOURCE_URL_FILE)
SUBDIR:=$(PKG_SOURCE_SUBDIR)
PROTO:=$(PKG_SOURCE_PROTO)
$(if $(PKG_SOURCE_MIRROR),MIRROR:=$(filter 1,$(PKG_MIRROR)))