aboutsummaryrefslogtreecommitdiffstats
path: root/include/depends.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-18 16:19:03 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-18 23:57:08 +0100
commit87d9e3462d25e16abb6b5c18da56312d7b90d7b6 (patch)
treea56342164b870eae167fdf3df5c06e225a5ba873 /include/depends.mk
parent8aa93dafc86d804a396fca42e5d7ecdffb53852d (diff)
downloadupstream-87d9e3462d25e16abb6b5c18da56312d7b90d7b6.tar.gz
upstream-87d9e3462d25e16abb6b5c18da56312d7b90d7b6.tar.bz2
upstream-87d9e3462d25e16abb6b5c18da56312d7b90d7b6.zip
build: stage unstripped packages inside PKG_BUILD_DIR
This makes the build slightly more efficient by avoiding the need to re-stage packages on every full build run. It is also necessary for the upcoming CONFIG_AUTOREMOVE feature Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/depends.mk')
-rw-r--r--include/depends.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/depends.mk b/include/depends.mk
index c26c8e547e..1b74a840b7 100644
--- a/include/depends.mk
+++ b/include/depends.mk
@@ -11,7 +11,7 @@
# 3: tempfile for file listings
# 4: find options
-DEP_FINDPARAMS := -x "*/.svn*" -x ".*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check" -x "*/.*.swp"
+DEP_FINDPARAMS := -x "*/.svn*" -x ".*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check" -x "*/.*.swp" -x "*/.pkgdir"
find_md5=find $(wildcard $(1)) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | mkhash md5