aboutsummaryrefslogtreecommitdiffstats
path: root/include/depends.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-02-05 22:17:24 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-05 22:17:30 +0100
commit40fb293f240f14013a203d553add70891d966e34 (patch)
tree1fda64a647e766eb3d3ac10305f8d50bbbe89cca /include/depends.mk
parent07d5fc7ada9734c198f0316a872d38932116e5b0 (diff)
downloadupstream-40fb293f240f14013a203d553add70891d966e34.tar.gz
upstream-40fb293f240f14013a203d553add70891d966e34.tar.bz2
upstream-40fb293f240f14013a203d553add70891d966e34.zip
build: add missing wildcard for ignoring .pkgdir in dependency checks
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/depends.mk')
-rw-r--r--include/depends.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/depends.mk b/include/depends.mk
index 1b74a840b7..3df51adae3 100644
--- a/include/depends.mk
+++ b/include/depends.mk
@@ -11,7 +11,7 @@
# 3: tempfile for file listings
# 4: find options
-DEP_FINDPARAMS := -x "*/.svn*" -x ".*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check" -x "*/.*.swp" -x "*/.pkgdir"
+DEP_FINDPARAMS := -x "*/.svn*" -x ".*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check" -x "*/.*.swp" -x "*/.pkgdir*"
find_md5=find $(wildcard $(1)) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | mkhash md5