aboutsummaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2017-01-18 19:47:36 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2017-01-18 19:47:36 +0100
commit3d71786154fbb3fcfbd652115f3e75db3f729941 (patch)
treea3d0ad55239a4a9bb526c88149e107a65fae6dc6 /include/autotools.mk
parent5f7a081553edcfe3cf4ed9601297a5a17616cf99 (diff)
downloadupstream-3d71786154fbb3fcfbd652115f3e75db3f729941.tar.gz
upstream-3d71786154fbb3fcfbd652115f3e75db3f729941.tar.bz2
upstream-3d71786154fbb3fcfbd652115f3e75db3f729941.zip
build: move STAGING_DIR_HOSTPKG and BUILD_DIR_HOST back to a common directory for all targets
Using a single host package staging dir (and build dir) significantly speeds up builds when multiple targets are built in succession, especially for large host packages like NodeJS. $(STAGING_DIR)/host is kept in addition to $(STAGING_DIR_HOSTPKG) in most places; it is still used as destination for host files in Build/InstallDev. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index c6aa47e0be..7bd400ab36 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -75,7 +75,7 @@ define autoreconf_target
$(strip $(call autoreconf, \
$(PKG_BUILD_DIR), $(PKG_REMOVE_FILES), \
$(PKG_AUTOMAKE_PATHS), $(PKG_LIBTOOL_PATHS), \
- $(STAGING_DIR)/host/share/aclocal $(STAGING_DIR)/usr/share/aclocal $(PKG_MACRO_PATHS)))
+ $(STAGING_DIR)/host/share/aclocal $(STAGING_DIR_HOSTPKG)/share/aclocal $(STAGING_DIR)/usr/share/aclocal $(PKG_MACRO_PATHS)))
endef
define patch_libtool_target