aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-01-07 01:57:01 +0100
committerPetr Štetiar <ynezz@true.cz>2019-07-25 07:48:02 +0200
commitfe928c7a81810fd84210a5e9594b7fa8ce1064ce (patch)
treeb942e8e153baa141e971c2796cbd94578b1f2542 /Makefile
parent273b803623c97432585bf0f8c19a580c4a405d91 (diff)
downloadupstream-fe928c7a81810fd84210a5e9594b7fa8ce1064ce.tar.gz
upstream-fe928c7a81810fd84210a5e9594b7fa8ce1064ce.tar.bz2
upstream-fe928c7a81810fd84210a5e9594b7fa8ce1064ce.zip
build: allow simple build system customization with local.mk
I tend to automate most of the boring and repetitive tasks like firmware flashing, build config reconfiguration etc., so I always end up adding `include local.mk` as a last line in my Makefile, where local.mk is usually symlink to some other place, just to not accidentally delete it during `git clean`. Carrying this single uncommited modification along in the development process is quite PITA, because it's causing problems during Git workflow, while rebasing etc. I hope, that I'm not alone using similar workflow, so I believe, that this modification might be useful for others as well. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 5301883061..1ccfd61d68 100644
--- a/Makefile
+++ b/Makefile
@@ -103,3 +103,5 @@ world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-
.PHONY: clean dirclean prereq prepare world package/symlinks package/symlinks-install package/symlinks-clean
endif
+
+-include local.mk