aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-29 11:26:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-29 11:26:35 +0000
commitf952681f35d4c023e933ce4b97f7f78cab74caf1 (patch)
tree81e8e1a54f3b72843f0ec2f1f0ad4b03be2ea451 /Makefile
parent4d8d4267144a74663eece82ef5b018ade4a607df (diff)
downloadupstream-f952681f35d4c023e933ce4b97f7f78cab74caf1.tar.gz
upstream-f952681f35d4c023e933ce4b97f7f78cab74caf1.tar.bz2
upstream-f952681f35d4c023e933ce4b97f7f78cab74caf1.zip
run metadata scanning only once when multiple targets are specified on the command line
SVN-Revision: 6754
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 9b358c3b7a..bee47c45cc 100644
--- a/Makefile
+++ b/Makefile
@@ -91,11 +91,14 @@ kernel_menuconfig: .config FORCE
-$(MAKE) target/linux-prepare
$(NO_TRACE_MAKE) -C target/linux menuconfig
-package/%:
+scan_packages:
@$(NO_TRACE_MAKE) -s tmp/.pkginfo tmp/.targetinfo
+
+
+package/%: scan_packages
$(MAKE) -C package $(patsubst package/%,%,$@)
-target/%:
+target/%: scan_packages
@$(NO_TRACE_MAKE) -s tmp/.pkginfo tmp/.targetinfo
$(MAKE) -C target $(patsubst target/%,%,$@)