aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-03-07 15:11:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-03-07 15:11:58 +0000
commitf103e28fba5a518b0a9de0ff330aa8be9d6e0280 (patch)
treef2a213804a45ef0d3d3672e5a70f8680c803bbdf /Makefile
parent4c0da7fa26e9c3554f2c7f146277eb0e05bdecb9 (diff)
downloadupstream-f103e28fba5a518b0a9de0ff330aa8be9d6e0280.tar.gz
upstream-f103e28fba5a518b0a9de0ff330aa8be9d6e0280.tar.bz2
upstream-f103e28fba5a518b0a9de0ff330aa8be9d6e0280.zip
create a package index after build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@337 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index ed4ea1529f..1a218df586 100644
--- a/Makefile
+++ b/Makefile
@@ -69,16 +69,13 @@ package_install: toolchain
# In this section, we need .config
include .config.cmd
-world: $(DL_DIR) $(BUILD_DIR) target_prepare $(TARGET_DIR) toolchain_install package_install target_install
+world: $(DL_DIR) $(BUILD_DIR) target_prepare $(TARGET_DIR) toolchain_install package_install target_install package_index
.PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install
-#############################################################
-#
-# staging and target directories do NOT list these as
-# dependancies anywhere else
-#
-#############################################################
+package_index:
+ $(STAGING_DIR)/usr/bin/ipkg-make-index $(PACKAGE_DIR) > $(PACKAGE_DIR)/Packages
+
target_prepare:
$(MAKE) -C target prepare