aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-01 00:19:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-01 00:19:52 +0000
commitee812fc4368f33e814b9ea615fb80281ebf10a7f (patch)
treeaafb1b5f7b4db60aa9d9a79f54fdc9d16bec2e53 /Makefile
parentbb032c2fc7b6d5c03e0f19ec577d943fd449a12f (diff)
downloadupstream-ee812fc4368f33e814b9ea615fb80281ebf10a7f.tar.gz
upstream-ee812fc4368f33e814b9ea615fb80281ebf10a7f.tar.bz2
upstream-ee812fc4368f33e814b9ea615fb80281ebf10a7f.zip
add clean targets, more FORCE stuff
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3882 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile27
1 files changed, 18 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 40b4efc044..84508b1ffc 100644
--- a/Makefile
+++ b/Makefile
@@ -61,36 +61,45 @@ scripts/config/mconf: .config.in
scripts/config/conf: .config.in
$(MAKE) -C scripts/config conf
-config: scripts/config/conf
+config: scripts/config/conf FORCE
$< Config.in
-defdconfig: scripts/config/conf
+defdconfig: scripts/config/conf FORCE
$< -d Config.in
-oldconfig: scripts/config/conf
+oldconfig: scripts/config/conf FORCE
$< -o Config.in
-menuconfig: scripts/config/mconf
+menuconfig: scripts/config/mconf FORCE
$< Config.in
-config-clean:
+config-clean: FORCE
$(MAKE) -C scripts/config clean
-package/%: .pkginfo
+package/%: .pkginfo FORCE
$(MAKE) -C package $(patsubst package/%,%,$@)
-target/%: .pkginfo
+target/%: .pkginfo FORCE
$(MAKE) -C target $(patsubst target/%,%,$@)
-toolchain/%:
+toolchain/%: FORCE
$(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
-world:
+world: FORCE
$(MAKE) toolchain/install
$(MAKE) target/compile
$(MAKE) package/compile
$(MAKE) package/install
$(MAKE) target/install
+clean: FORCE
+ rm -rf build_* bin
+
+dirclean: clean FORCE
+ rm -rf staging_dir_* toolchain_build_*
+
+distclean: dirclean FORCE
+ rm -rf .* dl
+
.PHONY: FORCE
FORCE: