aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-06 23:09:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-06 23:09:06 +0000
commitc3a9685aa3e03f7705f9584dfd7fb5b82166102a (patch)
tree6fd77e7868fac84096bd085d1bca8ebab316e653 /Makefile
parentc993ad73be467282f04a53e112cbd535498f2226 (diff)
downloadupstream-c3a9685aa3e03f7705f9584dfd7fb5b82166102a.tar.gz
upstream-c3a9685aa3e03f7705f9584dfd7fb5b82166102a.tar.bz2
upstream-c3a9685aa3e03f7705f9584dfd7fb5b82166102a.zip
use ~/.openwrt/defconfig as default config if it exists
SVN-Revision: 6876
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 414a152789..43ed005b8a 100644
--- a/Makefile
+++ b/Makefile
@@ -62,7 +62,10 @@ tmp/.config-%.in: tmp/.%info
.config: ./scripts/config/conf tmp/.config-target.in tmp/.config-package.in
- @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
+ @[ -f .config ] || { \
+ [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
+ $(NO_TRACE_MAKE) menuconfig; \
+ }
@$< -D .config Config.in &> /dev/null
scripts/config/mconf:
@@ -87,6 +90,8 @@ oldconfig: scripts/config/conf tmp/.config-target.in tmp/.config-package.in FORC
$< -o Config.in
menuconfig: scripts/config/mconf tmp/.config-target.in tmp/.config-package.in FORCE
+ @[ -f .config ] || \
+ [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config
$< Config.in
kernel_menuconfig: .config FORCE