aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-01-19 12:19:28 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-01-19 12:19:28 +0000
commitb81354d8286386adc010d3178bd153bf0f6fc661 (patch)
tree4c6d886803896ff26d997f0e5e88e0e5a40b5353 /Makefile
parent3d09c34dd3ee4dba023466acd9dda309a2f366f9 (diff)
downloadupstream-b81354d8286386adc010d3178bd153bf0f6fc661.tar.gz
upstream-b81354d8286386adc010d3178bd153bf0f6fc661.tar.bz2
upstream-b81354d8286386adc010d3178bd153bf0f6fc661.zip
abort built in prereq target if there is no site config file for the current target
SVN-Revision: 29798
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 4d5d7885e0..44b4e944eb 100644
--- a/Makefile
+++ b/Makefile
@@ -78,6 +78,12 @@ endif
# check prerequisites before starting to build
prereq: $(target/stamp-prereq) tmp/.prereq_packages
+ @if [ ! -f "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" ]; then \
+ echo 'ERROR: Missing site config for target "$(REAL_GNU_TARGET_NAME)" !'; \
+ echo ' The missing file will cause configure scripts to fail during compilation.'; \
+ echo ' Please provide a "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" file and restart the build.'; \
+ exit 1; \
+ fi
prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE