aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-16 16:59:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-16 16:59:44 +0000
commitb4f853be1898f720784fbdf3ee6718188c6c335c (patch)
tree90caca550f3e130f8ea4493e1f8691dbb03e12c5 /Makefile
parent86666298d70fb34fc6e383e1aa15e4ae1f4d4836 (diff)
downloadupstream-b4f853be1898f720784fbdf3ee6718188c6c335c.tar.gz
upstream-b4f853be1898f720784fbdf3ee6718188c6c335c.tar.bz2
upstream-b4f853be1898f720784fbdf3ee6718188c6c335c.zip
add top-level kernel_menuconfig target to unpack and reconfigure the kernel - uses config.pl to generate target/linux/*/config and config-diff
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6310 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 35fc2c8884..b1970b09cb 100644
--- a/Makefile
+++ b/Makefile
@@ -113,6 +113,10 @@ oldconfig: scripts/config/conf tmp/.config.in tmp/.config-target.in FORCE
menuconfig: scripts/config/mconf tmp/.config.in tmp/.config-target.in FORCE
$< Config.in
+kernel_menuconfig: .config FORCE
+ $(MAKE) target/linux-prepare
+ $(NO_TRACE_MAKE) -C target/linux menuconfig
+
package/%: tmp/.pkginfo tmp/.targetinfo FORCE
$(MAKE) -C package $(patsubst package/%,%,$@)