aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-06-14 17:47:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-06-14 17:47:16 +0000
commitb20a2b48901195a79d86eaecb386d45fe5d63c39 (patch)
tree7eec0b9bf66486f91abd853dab7507d19533dc87 /Makefile
parentffc033b26bb651af3b16dbd0044f770064fa2d0c (diff)
downloadupstream-b20a2b48901195a79d86eaecb386d45fe5d63c39.tar.gz
upstream-b20a2b48901195a79d86eaecb386d45fe5d63c39.tar.bz2
upstream-b20a2b48901195a79d86eaecb386d45fe5d63c39.zip
Makefile: move the cleaning of staging_dir/target* from dirclean to clean
Currently "make clean" only clears the build_dir/target*, but leaves staging_dir/target* intact. "make clean" should also clean the staging_dir/target* directories, as in the current situation some old packages or libraries may be linked into the firmware from staging_dir despite a "make clean". The patch reorganises clean / dirclean functionality so that * "make clean" also clears the staging_dir/target* in addition to build_dir/target*. * "make dirclean" clears toolchain and host(=tools) directories from both build_dir and staging_dir signed-off-by: Hannu Nyman <hannu.nyman@iki.fi> SVN-Revision: 45973
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index f89527f81c..a12e3ea49a 100644
--- a/Makefile
+++ b/Makefile
@@ -50,10 +50,10 @@ printdb:
prepare: $(target/stamp-compile)
clean: FORCE
- rm -rf $(BUILD_DIR) $(BIN_DIR) $(BUILD_LOG_DIR)
+ rm -rf $(BUILD_DIR) $(STAGING_DIR) $(BIN_DIR) $(BUILD_LOG_DIR)
dirclean: clean
- rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST) $(BUILD_DIR_TOOLCHAIN)
+ rm -rf $(STAGING_DIR_HOST) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST) $(BUILD_DIR_TOOLCHAIN)
rm -rf $(TMP_DIR)
ifndef DUMP_TARGET_DB